summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-12 22:17:30 +0200
committersballert2018-09-12 22:17:30 +0200
commit7b304b5f86f4d1f4d0000e414a5b0b039ea9dfd5 (patch)
treeab33039efd503f3d1ac8bc2003cada91c10afb7f
downloadaur-7b304b5f86f4d1f4d0000e414a5b0b039ea9dfd5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4579770c6627
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-anzu-git
+ pkgdesc = Emacs Port of anzu.vim
+ pkgver = r261.e6c56ca
+ pkgrel = 1
+ url = https://github.com/syohex/emacs-anzu
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-anzu
+ conflicts = emacs-anzu
+ source = git+https://github.com/syohex/emacs-anzu.git
+ sha256sums = SKIP
+
+pkgname = emacs-anzu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6584070b49a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="syohex"
+_gitrepo="emacs-anzu"
+
+pkgname=emacs-anzu-git
+pkgver=r261.e6c56ca
+pkgrel=1
+pkgdesc="Emacs Port of anzu.vim"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-anzu')
+conflicts=('emacs-anzu')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/anzu/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/anzu/
+}