summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie Beardslee2020-02-12 13:58:05 +1300
committerJamie Beardslee2020-02-12 13:58:05 +1300
commit01047fe4bac8ebbf0067c3b53bc4d3abbb94fb4f (patch)
tree336968c1aa1d2f2cbdf8ef1d26d14e6ce2a28472
downloadaur-01047fe4bac8ebbf0067c3b53bc4d3abbb94fb4f.tar.gz
first commit - created PKGBUILD, .SRCINFO
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c3a669774cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = emacs-eaf
+ pkgdesc = EAF extends GNU Emacs to an entire universe of powerful GUI applications.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/manateelazycat/emacs-application-framework
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = emacs python-dbus python-xlib python-qtpy python-pyqtwebengine python-qrcode python-feedparser python-pymupdf python-grip
+ source = git://github.com/manateelazycat/emacs-application-framework
+
+pkgname = emacs-eaf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5519ce6fe640
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jamie Beardslee
+# Emacs Application Framework written by Andy Stewart <lazycat.manatee@gmail.com>
+
+pkgname="emacs-eaf"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="EAF extends GNU Emacs to an entire universe of powerful GUI applications."
+arch=('x86_64')
+url="https://github.com/manateelazycat/emacs-application-framework"
+license=('GPL3')
+depends=('emacs' 'python-dbus' 'python-xlib' 'python-qtpy' 'python-pyqtwebengine' 'python-qrcode' 'python-feedparser' 'python-pymupdf' 'python-grip')
+makedepends=('git')
+provides=('emacs-eaf')
+conflicts=('emacs-eaf')
+source=("emacs-eaf::git://github.com/manateelazycat/emacs-application-framework")
+options=(!strip)
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/emacs-eaf"
+
+ mkdir -p "$pkgdir"/usr/share/emacs/site-lisp/eaf/
+ for _i in app core docker *.el *.py
+ do
+ cp -r ${_i} "$pkgdir"/usr/share/emacs/site-lisp/eaf/
+ done
+
+ mkdir -p "$pkgdir"/usr/share/doc/emacs-eaf/
+ cp README.md "$pkgdir"/usr/share/doc/emacs-eaf/README.md
+
+}