summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-12-12 22:50:26 +0100
committerhaawda2020-12-12 22:50:26 +0100
commit15dfa0b775d7b1f090873844ce67e96ab14fd464 (patch)
treeaa7a51e79eda7082f328e779aad4b8b0c0bdb6f3
parent7f9e41df700ef05bba426bf35d1466655fc00f36 (diff)
downloadaur-15dfa0b775d7b1f090873844ce67e96ab14fd464.tar.gz
initial upload
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD47
2 files changed, 55 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8442b8916ad..54d318dd7e9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,30 @@
-pkgbase = emacs-eaf
-pkgdesc = EAF extends GNU Emacs to an entire universe of powerful GUI applications.
-pkgver = 2.0.0
-pkgrel = 2
-url = https://github.com/manateelazycat/emacs-application-framework
-arch = x86_64
-license = GPL3
-makedepends = git
-depends = emacs
-depends = python-dbus
-depends = python-pyqt5
-depends = python-pyqtwebengine
-depends = wmctrl
-optdepends = python-pymupdf: for pdf viewer
-optdepends = python-grip: for markdown preview
-optdepends = python-qrcode: for qr codes
-optdepends = python-feedparser: for rss reader
-optdepends = python-pyinotify: for mermaid
-optdepends = python-markdown: for mermaid
-optdepends = nodejs: for terminal
-optdepends = aria2: for browser
-optdepends = libreoffice: doc viewer
-optdepends = filebrowser-bin: for file browser
-source = https://github.com/manateelazycat/emacs-application-framework
+pkgbase = emacs-application-framework-git
+ pkgdesc = EAF extends GNU Emacs to an entire universe of powerful GUI applications.
+ pkgver = r1587.9e1b531
+ pkgrel = 1
+ url = https://github.com/manateelazycat/emacs-application-framework
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = python-dbus
+ depends = python-pyqt5
+ depends = python-pyqtwebengine
+ depends = wmctrl
+ optdepends = python-pymupdf: for pdf viewer
+ optdepends = python-grip: for markdown preview
+ optdepends = python-qrcode: for qr codes
+ optdepends = python-feedparser: for rss reader
+ optdepends = python-pyinotify: for mermaid
+ optdepends = python-markdown: for mermaid
+ optdepends = nodejs: for mermaid
+ optdepends = aria2: for browser
+ optdepends = libreoffice: doc viewer
+ optdepends = filebrowser: for file browser
+ provides = emacs-eaf
+ conflicts = emacs-eaf
+ source = git+https://github.com/manateelazycat/emacs-application-framework
+ md5sums = SKIP
+
+pkgname = emacs-application-framework-git
-pkgname = emacs-eaf
diff --git a/PKGBUILD b/PKGBUILD
index e06041cb9d49..6b21d62cc61d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Jamie Beardslee
-# Emacs Application Framework written by Andy Stewart <lazycat.manatee@gmail.com>
+# Contributor: Jamie Beardslee
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname="emacs-eaf"
-pkgver=2.0.0
-pkgrel=2
+pkgname=emacs-application-framework-git
+pkgver=r1587.9e1b531
+pkgrel=1
pkgdesc="EAF extends GNU Emacs to an entire universe of powerful GUI applications."
-arch=('x86_64')
+arch=('any')
url="https://github.com/manateelazycat/emacs-application-framework"
license=('GPL3')
depends=('emacs' 'python-dbus' 'python-pyqt5' 'python-pyqtwebengine' 'wmctrl')
@@ -15,27 +15,32 @@ optdepends=('python-pymupdf: for pdf viewer'
'python-feedparser: for rss reader'
'python-pyinotify: for mermaid'
'python-markdown: for mermaid'
- 'nodejs: for terminal'
+ 'nodejs: for mermaid'
'aria2: for browser'
'libreoffice: doc viewer'
- 'filebrowser-bin: for file browser')
+ 'filebrowser: for file browser')
makedepends=('git')
provides=('emacs-eaf')
conflicts=('emacs-eaf')
-source=("emacs-eaf::https://github.com/manateelazycat/emacs-application-framework")
-options=(!strip)
+source=("git+https://github.com/manateelazycat/emacs-application-framework")
md5sums=('SKIP')
-package() {
- cd "$srcdir/emacs-eaf"
-
- mkdir -p "$pkgdir"/usr/share/emacs/site-lisp/eaf/
- for _i in app core docker *.el *.py
- do
- cp -r ${_i} "$pkgdir"/usr/share/emacs/site-lisp/eaf/
- done
-
- mkdir -p "$pkgdir"/usr/share/doc/emacs-eaf/
- cp README.md "$pkgdir"/usr/share/doc/emacs-eaf/README.md
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "${pkgname%-git}"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/eaf/
+ for _i in app core docker *.el *.py
+ do
+ cp -r ${_i} "$pkgdir"/usr/share/emacs/site-lisp/eaf/
+ done
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/emacs-eaf/README.md
+ # no binaries under /usr/share
+ rm "$pkgdir"/usr/share/emacs/site-lisp/eaf/app/terminal/node_modules/node-pty/build/Release/pty.node
+ rmdir "$pkgdir"/usr/share/emacs/site-lisp/eaf/app/terminal/node_modules/node-pty/build/Release
+ rm "$pkgdir"/usr/share/emacs/site-lisp/eaf/app/terminal/node_modules/node-pty/node_modules/nan
+ rmdir "$pkgdir"/usr/share/emacs/site-lisp/eaf/app/terminal/node_modules/node-pty/node_modules/
}