summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-13 14:54:45 +0200
committersballert2018-09-13 14:54:45 +0200
commitcb2275ac55f11587cdfb52974c1f5301dc6f3c09 (patch)
tree65918947845d08aaad62a6fbc14656a46b8e3fac
downloadaur-cb2275ac55f11587cdfb52974c1f5301dc6f3c09.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90e633c383d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-async-git
+ pkgdesc = Asynchronous processing in Emacs
+ pkgver = r272.d17c11e
+ pkgrel = 1
+ url = https://github.com/jwiegley/emacs-async
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-async
+ conflicts = emacs-async
+ source = git+https://github.com/jwiegley/emacs-async.git
+ sha256sums = SKIP
+
+pkgname = emacs-async-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7bf59dab2ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="jwiegley"
+_gitrepo="emacs-async"
+
+pkgname=emacs-async-git
+pkgver=r272.d17c11e
+pkgrel=1
+pkgdesc="Asynchronous processing in Emacs"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-async')
+conflicts=('emacs-async')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/async/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/async/
+}