summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-25 11:47:43 +0200
committerhaawda2018-08-25 11:47:43 +0200
commit9a66810c93e06df41ebcb61131bb80e5f3ba1523 (patch)
treeec90bf6e26721abaca3b70f3b5fbb591d0674fcb
parentab71e25529cfaa926ba24aeff5dbf584d395d609 (diff)
downloadaur-emacs-auto-complete.tar.gz
adopt and fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9612f9f0029e..5b55350e6825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu May 4 15:56:37 UTC 2017
pkgbase = emacs-auto-complete
pkgdesc = A auto-complete declaration for simplifying your .emacs
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/auto-complete/auto-complete
install = emacs-auto-complete.install
arch = any
@@ -13,7 +11,7 @@ pkgbase = emacs-auto-complete
depends = emacs-popup-el
depends = emacs-fuzzy
provides = emacs-auto-complete
- source = https://github.com/auto-complete/auto-complete/archive/v1.5.1.tar.gz
+ source = emacs-auto-complete-1.5.1.tar.gz::https://github.com/auto-complete/auto-complete/archive/v1.5.1.tar.gz
sha256sums = 1bfb4351c3e49681a875dab937c25b6b38e4bf8a8cd64bcba1954300242578cb
pkgname = emacs-auto-complete
diff --git a/PKGBUILD b/PKGBUILD
index b649309afb6c..f77f93d6a370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-auto-complete
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A auto-complete declaration for simplifying your .emacs"
url="https://github.com/auto-complete/auto-complete"
arch=('any')
@@ -10,17 +11,17 @@ license=('GPL3')
depends=('emacs' 'emacs-popup-el' 'emacs-fuzzy')
makedepends=('git')
provides=('emacs-auto-complete')
-source=("https://github.com/auto-complete/auto-complete/archive/v${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/auto-complete/auto-complete/archive/v${pkgver}.tar.gz")
sha256sums=('1bfb4351c3e49681a875dab937c25b6b38e4bf8a8cd64bcba1954300242578cb')
install=${pkgname}.install
build() {
- cd "${srcdir}/auto-complete-${pkgver}"
+ cd auto-complete-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/auto-complete-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/auto-complete"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/auto-complete/"
+ cd auto-complete-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/auto-complete
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/auto-complete/
}