summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-06 16:58:40 +0200
committersballert2018-09-06 16:58:40 +0200
commit09923bc8c648cdb5ce9812dffcc4b653027ca690 (patch)
tree757c3838d6780f5d87bee819aebb13f8cfe037f4
downloadaur-09923bc8c648cdb5ce9812dffcc4b653027ca690.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfff49586da2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-auto-dictionary-git
+ pkgdesc = Emacs: automatic dictionary switcher for flyspell
+ pkgver = r49.b364e08
+ pkgrel = 1
+ url = https://github.com/nschum/auto-dictionary-mode
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-auto-dictionary
+ conflicts = emacs-auto-dictionary
+ source = git+https://github.com/nschum/auto-dictionary-mode.git
+ sha256sums = SKIP
+
+pkgname = emacs-auto-dictionary-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..320b1354f07f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="nschum"
+_gitrepo="auto-dictionary-mode"
+
+pkgname=emacs-auto-dictionary-git
+pkgver=r49.b364e08
+pkgrel=1
+pkgdesc="Emacs: automatic dictionary switcher for flyspell"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-auto-dictionary')
+conflicts=('emacs-auto-dictionary')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}