summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-06-03 15:39:08 -0400
committerAlex Whitt2017-06-03 15:39:08 -0400
commitcc9d65e51f4a96bc95e864015147659d2a99d522 (patch)
treebab129e6f47f51afe562aeef05423817ab51a387
downloadaur-cc9d65e51f4a96bc95e864015147659d2a99d522.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-cider.install24
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44a751c771d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jun 3 19:36:59 UTC 2017
+pkgbase = emacs-cider
+ pkgdesc = The Clojure Interactive Development Environment that Rocks for Emacs
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://github.com/clojure-emacs/cider
+ install = emacs-cider.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-clojure-mode
+ depends = emacs-pkg-info
+ depends = emacs-queue
+ depends = emacs-spinner
+ source = emacs-cider-0.14.0.tar.gz::https://github.com/clojure-emacs/cider/archive/v0.14.0.tar.gz
+ sha256sums = 7dafbbc43aa36c84a4fba72d9a8a25a7cc98dd0161aaeb038c576fc0c65e759c
+
+pkgname = emacs-cider
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcafdd1705f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=cider
+_pkgmaintainer=clojure-emacs
+_pkgdestdirname=cider
+_versionprefix=v
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="The Clojure Interactive Development Environment that Rocks for Emacs"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs' 'emacs-clojure-mode' 'emacs-pkg-info' 'emacs-queue' 'emacs-spinner')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('7dafbbc43aa36c84a4fba72d9a8a25a7cc98dd0161aaeb038c576fc0c65e759c')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-cider.install b/emacs-cider.install
new file mode 100644
index 000000000000..3855d6497b51
--- /dev/null
+++ b/emacs-cider.install
@@ -0,0 +1,24 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'cider)
+
+==> Or, with use-package:
+
+(use-package cider)
+
+==> From the README:
+
+Simply open in Emacs a file belonging to your lein or boot project (like foo.clj) and type M-x cider-jack-in. This will start an nREPL server with all the project dependencies loaded in and CIDER will automatically connect to it.
+
+Alternatively you can use C-u M-x cider-jack-in to specify the name of a lein or boot project, without having to visit any file in it.
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}