summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-27 13:11:24 -0400
committerAlex Whitt2017-04-27 13:11:24 -0400
commit49e775e9bfc7af9b4eff77aa26d9c31c290e507f (patch)
treed6558d1ed1a10bbae976b3d3639926995a2407ca
downloadaur-49e775e9bfc7af9b4eff77aa26d9c31c290e507f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1e773f309c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 17:10:51 UTC 2017
+pkgbase = emacs-counsel-projectile
+ pkgdesc = Ivy UI for Projectile
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ericdanan/counsel-projectile
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-swiper
+ depends = emacs-projectile
+ source = https://github.com/ericdanan/counsel-projectile/archive/master.zip
+ sha256sums = SKIP
+
+pkgname = emacs-counsel-projectile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4271d81a5d03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-counsel-projectile
+pkgver=0.1
+pkgrel=1
+pkgdesc="Ivy UI for Projectile"
+arch=(any)
+url="https://github.com/ericdanan/counsel-projectile"
+license=('GPL3')
+depends=('emacs' 'emacs-swiper' 'emacs-projectile')
+source=("https://github.com/ericdanan/counsel-projectile/archive/master.zip")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/counsel-projectile-master"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/counsel-projectile-master"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/counsel-projectile/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/counsel-projectile/"
+}