summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-25 12:36:15 +0200
committerhaawda2018-08-25 12:36:15 +0200
commit4b0162651279751079e090801bf9e2337fcf1b38 (patch)
tree242f77ce88833445075243ce01bf7a3b8346c3c2
parent7bcef3260e0a20ebef183535ec3b2cce1494b50b (diff)
downloadaur-4b0162651279751079e090801bf9e2337fcf1b38.tar.gz
adopt
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cde285027035..86f91f3007f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
-# Generated by mksrcinfo v8
-# Thu Apr 27 19:35:08 UTC 2017
pkgbase = emacs-ctable
pkgdesc = Table Component for elisp
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kiwanami/emacs-ctable
arch = any
license = GPL3
- makedepends = git
depends = emacs
- provides = emacs-ctable
- source = https://github.com/kiwanami/emacs-ctable/archive/0.1.2.tar.gz
- sha256sums = SKIP
+ source = emacs-ctable-0.1.2.tar.gz::https://github.com/kiwanami/emacs-ctable/archive/0.1.2.tar.gz
+ sha256sums = 08da7bb579ef4c37cf972fd5cd9a5a990ed7220abe55fcfa0e27078c77c079d3
pkgname = emacs-ctable
diff --git a/PKGBUILD b/PKGBUILD
index 731f0ed1c845..ba9080022474 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-ctable
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Table Component for elisp"
url="https://github.com/kiwanami/emacs-ctable"
arch=('any')
license=('GPL3')
depends=('emacs')
-makedepends=('git')
-provides=('emacs-ctable')
-source=("https://github.com/kiwanami/emacs-ctable/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kiwanami/emacs-ctable/archive/${pkgver}.tar.gz")
+sha256sums=('08da7bb579ef4c37cf972fd5cd9a5a990ed7220abe55fcfa0e27078c77c079d3')
build() {
- cd "${srcdir}/emacs-ctable-${pkgver}"
+ cd emacs-ctable-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile ctable*.el
}
package() {
- cd "${srcdir}/emacs-ctable-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/ctable"
- install -m644 ctable*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/ctable/"
-} \ No newline at end of file
+ cd emacs-ctable-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/ctable
+ install -m644 ctable*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/ctable/
+}