summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Oteiza2015-06-08 22:51:43 -0400
committerMark Oteiza2015-06-08 22:51:43 -0400
commitc3381d989cc10e42cc517c0997315efdd261e076 (patch)
tree4889f1f98fcc8d716bdd7bbf6b3bb9e987a8c339
downloadaur-c3381d989cc10e42cc517c0997315efdd261e076.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67a7e5ed8d1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-dash
+ pkgdesc = A modern list API for Emacs
+ pkgver = 2.10.0
+ pkgrel = 1
+ url = https://github.com/magnars/dash.el
+ arch = any
+ license = GPL
+ makedepends = emacs
+ depends = emacs
+ source = https://github.com/magnars/dash.el/archive/2.10.0.tar.gz
+ source = https://github.com/magnars/dash.el/commit/dab0d1c.patch
+ sha256sums = cf94c9b8b4ef951aebf068172f139d511d71520569c361db73877808981f05fe
+ sha256sums = e5845b5025e7d7b4d6dfd4619ff3d76c8ec01424b90ab86743baf168d93ec239
+
+pkgname = emacs-dash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..964e33af1c53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: holos
+# Contributor: Sebastien Duthil <duthils@free.fr>
+
+pkgname=emacs-dash
+pkgver=2.10.0
+pkgrel=1
+pkgdesc='A modern list API for Emacs'
+arch=('any')
+url="https://github.com/magnars/dash.el"
+license=('GPL')
+makedepends=('emacs')
+depends=('emacs')
+source=("https://github.com/magnars/dash.el/archive/$pkgver.tar.gz"
+ 'https://github.com/magnars/dash.el/commit/dab0d1c.patch')
+sha256sums=('cf94c9b8b4ef951aebf068172f139d511d71520569c361db73877808981f05fe'
+ 'e5845b5025e7d7b4d6dfd4619ff3d76c8ec01424b90ab86743baf168d93ec239')
+
+prepare() {
+ cd dash.el-"$pkgver"
+ patch -p1 < ../dab0d1c.patch
+}
+
+build() {
+ cd dash.el-"$pkgver"
+ emacs -batch -L . -f batch-byte-compile dash{,-functional}.el
+}
+
+package() {
+ cd dash.el-"$pkgver"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/dash
+ install -Dm644 dash{,-functional}.{el,elc} "$pkgdir"/usr/share/emacs/site-lisp/dash
+ gzip "$pkgdir"/usr/share/emacs/site-lisp/dash/*.el
+}