summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-09 08:27:53 +0200
committersballert2018-09-09 08:27:53 +0200
commit891facc619f4c79f0fcee308870bdd8fa18da846 (patch)
tree152278db17c6eefe5387c9587d2bd255f5ce5a1e
downloadaur-891facc619f4c79f0fcee308870bdd8fa18da846.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f4f25fa3a00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-diminish-git
+ pkgdesc = Diminished modes are minor modes with no modeline display
+ pkgver = r14.565a983
+ pkgrel = 1
+ url = https://github.com/myrjola/diminish.el
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-diminish
+ conflicts = emacs-diminish
+ source = git+https://github.com/myrjola/diminish.el.git
+ sha256sums = SKIP
+
+pkgname = emacs-diminish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fa37f86f80f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="myrjola"
+_gitrepo="diminish.el"
+
+pkgname=emacs-diminish-git
+pkgver=r14.565a983
+pkgrel=1
+pkgdesc="Diminished modes are minor modes with no modeline display"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-diminish')
+conflicts=('emacs-diminish')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/diminish/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/diminish/
+}