summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-02 12:43:43 +0200
committersballert2018-09-02 12:43:43 +0200
commit4ac22e5f9d4800d33f703c3ce731317788031c80 (patch)
tree30da91bc2af650074b7b78be9be190b3c8b7a5f2
downloadaur-4ac22e5f9d4800d33f703c3ce731317788031c80.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbf589834707
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = emacs-doom-modeline-git
+ pkgdesc = A fancy mode-line from DOOM Emacs.
+ pkgver = r181.ac03729
+ pkgrel = 1
+ url = https://github.com/seagle0128/doom-modeline
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-all-the-icons
+ depends = emacs-dash
+ depends = emacs-eldoc-eval
+ depends = emacs-projectile
+ depends = emacs-shrink-path
+ provides = emacs-doom-modeline
+ conflicts = emacs-doom-modeline
+ source = git+https://github.com/seagle0128/doom-modeline.git
+ sha256sums = SKIP
+
+pkgname = emacs-doom-modeline-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d3d5bfcbe1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="seagle0128"
+_gitrepo="doom-modeline"
+
+pkgname=emacs-doom-modeline-git
+pkgver=r181.ac03729
+pkgrel=1
+pkgdesc="A fancy mode-line from DOOM Emacs."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-all-the-icons' 'emacs-dash' 'emacs-eldoc-eval'
+'emacs-projectile' 'emacs-shrink-path')
+makedepends=('git')
+provides=('emacs-doom-modeline')
+conflicts=('emacs-doom-modeline')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}