summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsben Haabendal2016-06-15 11:33:30 +0200
committerEsben Haabendal2016-06-15 11:33:30 +0200
commitc169c3577f247cfa4460c2a58e9ecf92b4d10a8b (patch)
treeb1c5d48b3549e8b77029d04f8a7414a8e1e80a44
downloadaur-c169c3577f247cfa4460c2a58e9ecf92b4d10a8b.tar.gz
Initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
-rw-r--r--emacs-editorconfig-git.install20
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aece7aedfe41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jun 15 09:13:49 UTC 2016
+pkgbase = emacs-editorconfig-git
+ pkgdesc = EditorConfig Emacs Plugin
+ pkgver = 0.7.6
+ pkgrel = 1
+ url = http://github.com/editorconfig-emacs/editorconfig-emacs
+ install = emacs-editorconfig-git.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = git
+ depends = editorconfig-core-c
+ provides = emacs-editorconfig
+ source = git+https://github.com/editorconfig-emacs/editorconfig-emacs.git
+ md5sums = SKIP
+
+pkgname = emacs-editorconfig-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e89655f49d60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Esben Haabendal <esben@haabendal.dk>
+
+pkgname=emacs-editorconfig-git
+_gitproj="editorconfig"
+_gitrepo="editorconfig-emacs"
+pkgver=0.7.6
+pkgrel=1
+pkgdesc="EditorConfig Emacs Plugin"
+arch=('any')
+url="http://github.com/${_gitproj}/${_gitrepo}"
+license=('GPL3')
+depends=('emacs' 'git' 'editorconfig-core-c')
+provides=('emacs-editorconfig')
+install="${pkgname}.install"
+source=("git+https://github.com/${_gitproj}/${_gitrepo}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ # Latest annotated tag (release)
+ git describe --abbrev=0 --tags | sed 's/^v//'
+}
+
+build() {
+ cd "$_gitrepo"
+ make LOAD_PATH="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L ${srcdir}" \
+ all
+}
+
+package() {
+ cd "$_gitrepo"
+ mkdir -p ${pkgdir}/usr/share/emacs/site-lisp/editorconfig-emacs
+ cp *.el* ${pkgdir}/usr/share/emacs/site-lisp/editorconfig-emacs
+}
diff --git a/emacs-editorconfig-git.install b/emacs-editorconfig-git.install
new file mode 100644
index 000000000000..cdd21bc020d9
--- /dev/null
+++ b/emacs-editorconfig-git.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(editorconfig-emacs.info)
+
+post_install() {
+ cat << EOF
+==> In order to use editorconfig-emacs, add the following lines to your
+~/.emacs file:
+
+(require 'editorconfig)
+(editorconfig-mode 1)
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*