summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhamki2021-06-18 18:46:57 +0800
committerhamki2021-06-18 18:46:57 +0800
commitbff1ba3af02960b3bfad1f81cba9c65d2fd939c3 (patch)
tree20cc0be04afb1ba697d4b90e2ec14f5430906a47
downloadaur-bff1ba3af02960b3bfad1f81cba9c65d2fd939c3.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aff24fbbe7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = emacs-emacsql
+ pkgdesc = EmacSQL is a high-level Emacs Lisp front-end for SQLite (primarily), PostgreSQL, MySQL, and potentially other SQL databases.
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/skeeto/emacsql
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = https://github.com/skeeto/emacsql/archive/refs/tags/3.0.0.tar.gz
+ sha256sums = 9d94be00518591c68cb0ed1de9dab885e35079f581fb0ae52af5af139a0f1088
+
+pkgname = emacs-emacsql
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42092c125ed7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer:
+
+pkgname=emacs-emacsql
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="EmacSQL is a high-level Emacs Lisp front-end for SQLite (primarily), PostgreSQL, MySQL, and potentially other SQL databases."
+arch=('any')
+url="https://github.com/skeeto/emacsql"
+license=('GPL3')
+depends=('emacs')
+source=("https://github.com/skeeto/emacsql/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('9d94be00518591c68cb0ed1de9dab885e35079f581fb0ae52af5af139a0f1088')
+
+build() {
+ cd emacsql-$pkgver
+ make LDFLAGS='-L /usr/share/emacs/site-lisp/emacs-pg'
+}
+
+package() {
+ cd emacsql-$pkgver
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/emacs-emacsql
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/emacs-emacsql
+}