summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:17:40 +0200
committerStefan Husmann2015-06-09 00:17:40 +0200
commit587a7bc204fa8cee4cfb5a14625266d6535024dc (patch)
tree6938e242c5bb16b492e9af9713ba16c1cbf02db0
downloadaur-587a7bc204fa8cee4cfb5a14625266d6535024dc.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--ess.install17
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ac0e3cbaafb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-ess
+ pkgdesc = Emacs Speaks Statistics: A Universal Interface for Statistical Analysis
+ pkgver = 15.03.1
+ pkgrel = 1
+ url = http://ess.r-project.org/
+ install = ess.install
+ arch = any
+ license = GPL
+ depends = emacs
+ depends = r
+ provides = ess
+ replaces = ess
+ source = http://ess.r-project.org/downloads/ess/ess-15.03-1.tgz
+ md5sums = 36ddd32daa346a36660cce176e36e617
+
+pkgname = emacs-ess
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0b8bc1b2d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Husmann <Stefan-Husmann@t-online.de>
+pkgname=emacs-ess
+pkgver=15.03.1
+pkgrel=1
+pkgdesc="Emacs Speaks Statistics: A Universal Interface for Statistical Analysis"
+url="http://ess.r-project.org/"
+arch=('any')
+license=('GPL')
+depends=('emacs' 'r')
+replaces=('ess')
+provides=('ess')
+install=ess.install
+source=("http://ess.r-project.org/downloads/ess/ess-15.03-1.tgz")
+md5sums=('36ddd32daa346a36660cce176e36e617')
+
+build() {
+ cd $srcdir/ess-15.03-1
+ make prefix=/usr
+}
+package() {
+ cd $srcdir/ess-15.03-1
+ make DESTDIR=$pkgdir/usr INFODIR=$pkgdir/usr/share/info/ install
+}
diff --git a/ess.install b/ess.install
new file mode 100644
index 000000000000..d06e4da2ce6f
--- /dev/null
+++ b/ess.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo "Please put the lines"
+ echo "(setq load-path (cons \"/usr/share/emacs/site-lisp/ess\" load-path))"
+ echo "(require 'ess-site)"
+ echo "to your ~/.emacs"
+ install-info /usr/share/info/ess.info.gz /usr/share/info/dir
+}
+post_update() {
+ post_install
+}
+pre_remove() {
+ echo "Please remove the line containing"
+ echo "(setq load-path (cons \"/usr/share/emacs/site-lisp/ess\" load-path))"
+ echo "(load \"/usr/share/emacs/site-lisp/ess/ess-site\")"
+ echo "from your ~/.emacs"
+ install-info --delete /usr/share/info/ess.info.gz /usr/share/info/dir
+} \ No newline at end of file