summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-10-23 21:09:06 +0200
committerhaawda2018-10-23 21:09:06 +0200
commitbabf4f4a8a8c255bf7a56414f034a085ee8d9fd0 (patch)
tree67ed32f424ec667080dd33e2f0f9945ad8309431
parenta62887c6736729330adad907de17e5e7f96d7928 (diff)
downloadaur-babf4f4a8a8c255bf7a56414f034a085ee8d9fd0.tar.gz
remove broken html generation
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--no-html.diff75
3 files changed, 100 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ead3e3c102f..f2b0be5a303c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Oct 23 19:08:59 UTC 2018
pkgbase = emacs-ess
pkgdesc = Emacs Speaks Statistics: A Universal Interface for Statistical Analysis
- pkgver = 18.10
- pkgrel = 3
+ pkgver = 18.10.1
+ pkgrel = 1
url = http://ess.r-project.org/
install = ess.install
arch = any
@@ -9,11 +11,12 @@ pkgbase = emacs-ess
makedepends = wget
depends = emacs
depends = r
- source = http://ess.r-project.org/downloads/ess/ess-18.10.tgz
- source = http://ess.r-project.org/downloads/ess/ess-18.10.tgz.sig
- validpgpkeys = 3808603281971CFF6949D38A1248E0A068E0DB0F
- sha256sums = b9029347079af5487f0cab6ccfdbeb8da3ab2c8f3513a907666bbb9aa6893417
+ source = http://ess.r-project.org/downloads/ess/ess-18.10-1.tgz
+ source = http://ess.r-project.org/downloads/ess/ess-18.10-1.tgz.sig
+ source = no-html.diff
+ sha256sums = 918537a62be6c3f5cef992787286ebbb0bb7cc75dad5124dc52ab1a57eb32b0c
sha256sums = SKIP
+ sha256sums = eda5cc1256e8470b92986c701fb4a7a2ddda25ce631a521f19d63afdc3cebb4b
pkgname = emacs-ess
diff --git a/PKGBUILD b/PKGBUILD
index 135cb22b3c00..ec37950848e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Stefan Husmann <Stefan-Husmann@t-online.de>
pkgname=emacs-ess
-pkgver=18.10
-pkgrel=3
+pkgver=18.10.1
+_pkgver=18.10-1
+pkgrel=1
pkgdesc="Emacs Speaks Statistics: A Universal Interface for Statistical Analysis"
url="http://ess.r-project.org/"
arch=('any')
@@ -10,16 +11,23 @@ license=('GPL')
depends=('emacs' 'r')
makedepends=('wget')
install=ess.install
-source=("http://ess.r-project.org/downloads/ess/ess-${pkgver}.tgz"{,.sig})
-sha256sums=('b9029347079af5487f0cab6ccfdbeb8da3ab2c8f3513a907666bbb9aa6893417'
- 'SKIP')
+source=("http://ess.r-project.org/downloads/ess/ess-${_pkgver}.tgz"{,.sig} no-html.diff)
+sha256sums=('918537a62be6c3f5cef992787286ebbb0bb7cc75dad5124dc52ab1a57eb32b0c'
+ 'SKIP'
+ 'eda5cc1256e8470b92986c701fb4a7a2ddda25ce631a521f19d63afdc3cebb4b')
validpgpkeys=('3808603281971CFF6949D38A1248E0A068E0DB0F') # Martin Maechler, ETHZ
build() {
- cd ess-$pkgver
- make prefix=/usr
+ cd ess-$_pkgver
+ make prefix=/usr all
}
+
+prepare() {
+ cd ess-$_pkgver
+ patch -Np1 < "$srcdir"/no-html.diff
+}
+
package() {
- cd ess-$pkgver
+ cd ess-$_pkgver
make DESTDIR="$pkgdir"/usr INFODIR="$pkgdir"/usr/share/info/ install
}
diff --git a/no-html.diff b/no-html.diff
new file mode 100644
index 000000000000..3c47af51202a
--- /dev/null
+++ b/no-html.diff
@@ -0,0 +1,75 @@
+diff --git a/Makeconf b/Makeconf
+index f8c3fd2a..59292a4b 100644
+--- a/Makeconf
++++ b/Makeconf
+@@ -70,8 +70,6 @@ EMACSBATCH = $(EMACS) -batch -no-site-file -no-init-file
+ SHELL = /bin/sh
+
+ MAKEINFO = LC_ALL=C LANG=en makeinfo
+-# new: MAKEHTML <output>.html <input>.texi {necessary to build 'Index'}
+-MAKEHTML = $(MAKEINFO) --html --no-split --css-include=atouchofstyle.css -o
+ ## ^^^^^^^^^^ today's bandwidth is fast
+ #MAKETXT = $(MAKEINFO) --no-validate --no-headers --no-split -o -
+ MAKETXT = $(MAKEINFO) --no-validate --plaintext --no-split -o -
+diff --git a/doc/Makefile b/doc/Makefile
+index 9514c1a2..644cfb7d 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -37,7 +37,6 @@ TXTs = ../README ../ANNOUNCE ../NEWS ../ONEWS
+ all : info text
+ info : info/ess.info
+ text : $(TXTs)
+-html : html/ess.html html/readme.html html/news.html
+ pdf : $(PDFs)
+
+ ess.pdf : $(TEXISRC)
+@@ -93,10 +92,9 @@ install-info : info/ess.info
+ echo $(ESSINFONODE1) $(ESSINFONODE2) >> $(INFODIR)/dir; \
+ echo $(ESSINFONODE3) >> $(INFODIR)/dir)
+
+-install-other-docs: pdf html
++install-other-docs: pdf
+ -$(INSTALLDIR) $(DOCDIR)
+ $(INSTALL) ess.pdf readme.pdf $(DOCDIR)
+- $(INSTALL) html/ess.html html/readme.html html/news.html $(DOCDIR)
+ $(INSTALL) refcard/refcard.pdf $(DOCDIR)
+
+ uninstall :
+@@ -104,24 +102,6 @@ uninstall :
+ -cd $(DOCDIR) && $(UNINSTALL) ess.html readme.html news.html
+ -cd $(DOCDIR) && $(UNINSTALL) refcard.pdf
+
+-## TO DO: ess_toc.html & readme_toc.html should be merged into index.html
+-html/ess.html: $(TEXISRC)
+- @echo "making HTML documentation..."
+- mkdir -p html
+- -$(MAKEHTML) html/ess.html ess.texi
+-#MM $(TEXI2HTML) $(SPLITCHAP) ess.texi
+-#MM test -d ess && cp -p ess/ess_toc.html html/index.html || cp -p ess_toc.html html/index.html
+-#MM test -d ess && mv -f ess/*.html html || mv -f *.html html
+-
+-html/readme.html: $(TEXISRC)
+- -$(MAKEHTML) html/readme.html --no-validate readme.texi
+- ## ^^^^^^^^^^^^^ (design bug: "FIXME" in ess.texi)
+-#MM $(TEXI2HTML) readme.texi
+-# mv -f readme.html html
+-
+-html/news.html: $(TEXISRC)
+- mkdir -p html
+- -$(MAKEHTML) html/news.html allnews.texi
+
+ refcard/refcard.pdf: refcard/refcard.tex
+ (cd refcard ; pdflatex refcard)
+diff --git a/lisp/Makefile b/lisp/Makefile
+index 1ecce2fd..11d0a9d6 100644
+--- a/lisp/Makefile
++++ b/lisp/Makefile
+@@ -40,7 +40,7 @@ dist: all
+ install: dist
+ -$(INSTALLDIR) $(LISPDIR)
+ $(INSTALL) *.elc $(LISPDIR)
+- $(INSTALL) obsolete/*.elc $(LISPDIR)
++ $(INSTALL) *.elc $(LISPDIR)
+ -export J; for I in *.elc; do J=$$I; $(INSTALL) `basename $$J .elc`.el $(LISPDIR); done
+ if [ -f /etc/debian_version -a -n "$(SITELISP)" -a ! -f "$(SITELISP)/ess-site.el" ] ; \
+ then \