summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-01 19:24:12 +0200
committersballert2018-09-01 19:24:12 +0200
commit4544532c2af5cede260d90698a343d17eec81d65 (patch)
treebd38f61cf03a1d307f125c5d84f1550cfe71dfe5
downloadaur-4544532c2af5cede260d90698a343d17eec81d65.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e0f5ad46d93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = emacs-evil-git
+ pkgdesc = The extensible vi layer for Emacs.
+ pkgver = r2099.3d9f76f
+ pkgrel = 1
+ url = https://github.com/emacs-evil/evil
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-goto-chg
+ depends = emacs-undo-tree
+ provides = emacs-evil
+ conflicts = emacs-evil
+ source = git+https://github.com/emacs-evil/evil.git
+ sha256sums = SKIP
+
+pkgname = emacs-evil-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..659d6ebb245f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="emacs-evil"
+_gitrepo="evil"
+
+pkgname=emacs-evil-git
+pkgver=r2099.3d9f76f
+pkgrel=1
+pkgdesc="The extensible vi layer for Emacs."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-goto-chg' 'emacs-undo-tree')
+makedepends=('git')
+provides=('emacs-evil')
+conflicts=('emacs-evil')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ make
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}