summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinRs2019-04-21 20:01:09 +0800
committerLinRs2019-04-21 20:57:12 +0800
commitdf3d764002695434fcb5c14165dd874b22517939 (patch)
tree3824cd44516a1d8926b1b99bdcd758410be41de6
parent4544532c2af5cede260d90698a343d17eec81d65 (diff)
downloadaur-df3d764002695434fcb5c14165dd874b22517939.tar.gz
upgpkg: emacs-evil-git 1.2.14.r3.g297b8f3-1
- add `install` file - use git tag number in pkgver array - add info manual for `evil mode`
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
-rw-r--r--emacs-evil.install13
3 files changed, 33 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e0f5ad46d93..932d07d4b906 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = emacs-evil-git
pkgdesc = The extensible vi layer for Emacs.
- pkgver = r2099.3d9f76f
+ pkgver = 1.2.14.r3.g297b8f3
pkgrel = 1
url = https://github.com/emacs-evil/evil
+ install = emacs-evil.install
arch = any
license = GPL3
makedepends = git
depends = emacs
- depends = emacs-goto-chg
depends = emacs-undo-tree
provides = emacs-evil
conflicts = emacs-evil
diff --git a/PKGBUILD b/PKGBUILD
index 659d6ebb245f..2a1598f0243f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,43 @@
-# Maintainer: sballert <sballert@posteo.de>
+# Maintainer: LinRs <LinRs AT users.noreply.github.com>
+# Contributor: sballert <sballert@posteo.de>
_gituser="emacs-evil"
_gitrepo="evil"
pkgname=emacs-evil-git
-pkgver=r2099.3d9f76f
+pkgver=1.2.14.r3.g297b8f3
pkgrel=1
pkgdesc="The extensible vi layer for Emacs."
url="https://github.com/${_gituser}/${_gitrepo}"
arch=('any')
license=('GPL3')
-depends=('emacs' 'emacs-goto-chg' 'emacs-undo-tree')
+depends=('emacs' 'emacs-undo-tree')
makedepends=('git')
provides=('emacs-evil')
conflicts=('emacs-evil')
source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+install="${_gituser}.install"
sha256sums=('SKIP')
pkgver() {
cd "$_gitrepo"
- printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "$_gitrepo"
- make
+ cd "${srcdir}/${_gitrepo}"
+ make info
+ make all
}
package() {
- cd "$_gitrepo"
- install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
- install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ cd "${srcdir}/${_gitrepo}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/${_gitrepo}"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_gitrepo}/"
+ cd "${srcdir}/${_gitrepo}/doc"
+ install -d "${pkgdir}/usr/share/info"
+ install -m644 ${_gitrepo}.info "${pkgdir}/usr/share/info/"
}
diff --git a/emacs-evil.install b/emacs-evil.install
new file mode 100644
index 000000000000..7b659fd32b50
--- /dev/null
+++ b/emacs-evil.install
@@ -0,0 +1,13 @@
+post_install() {
+cat << EOF
+
+>>> (add-to-list 'load-path "~/.emacs.d/evil")
+>>> (require 'evil)
+>>> (evil-mode 1)
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file