summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-05 15:37:04 +0200
committersballert2018-09-05 15:37:04 +0200
commite5230096dd075f6c0b1a92b43f3f6d39e2cc281a (patch)
tree92c29105a5a43356671e2a89fa3bd97b0f032e6e
downloadaur-e5230096dd075f6c0b1a92b43f3f6d39e2cc281a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e35aa974c85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-evil-org-git
+ pkgdesc = Supplemental evil-mode keybindings to emacs org-mode
+ pkgver = r168.b6d652a
+ pkgrel = 1
+ url = https://github.com/Somelauw/evil-org-mode
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-evil
+ provides = emacs-evil-org
+ conflicts = emacs-evil-org
+ source = git+https://github.com/Somelauw/evil-org-mode.git
+ sha256sums = SKIP
+
+pkgname = emacs-evil-org-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f02b9b8842a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="Somelauw"
+_gitrepo="evil-org-mode"
+
+pkgname=emacs-evil-org-git
+pkgver=r168.b6d652a
+pkgrel=1
+pkgdesc="Supplemental evil-mode keybindings to emacs org-mode"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-evil')
+makedepends=('git')
+provides=('emacs-evil-org')
+conflicts=('emacs-evil-org')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ rm evil-org-test.el
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}