summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-24 14:32:38 -0400
committerAlex Whitt2017-04-24 14:32:38 -0400
commit58e123abbf5c227c159c284b732e0d6b6f96bc3d (patch)
treed38eb462a052aa2ef87ae007dbfdef0990914b82
downloadaur-58e123abbf5c227c159c284b732e0d6b6f96bc3d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b492c6cc085
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 24 18:28:21 UTC 2017
+pkgbase = emacs-evil-surround
+ pkgdesc = you will be surrounded (surround.vim for evil, the extensible vi layer)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/timcharper/evil-surround
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs emacs-evil
+ provides = emacs-evil-surround
+ source = https://github.com/timcharper/evil-surround/archive/v1.0.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-evil-surround
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6966a2b27405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-evil-surround
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="you will be surrounded (surround.vim for evil, the extensible vi layer)"
+url="https://github.com/timcharper/evil-surround"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-evil')
+makedepends=('git')
+provides=('emacs-evil-surround')
+source=("https://github.com/timcharper/evil-surround/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/evil-surround-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/evil-surround-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/evil-surround"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/evil-surround/"
+}