summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-12 20:49:37 +0200
committersballert2018-09-12 20:49:37 +0200
commit72bdbd12155dbeb388d8c3f9fc69b65879bdcd25 (patch)
treee7d4659ba76a7722b1cbb90479e0a8586efb933a
downloadaur-emacs-evil-surround-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edf376b92876
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-evil-surround-git
+ pkgdesc = you will be surrounded (surround.vim for evil, the extensible vi layer)
+ pkgver = r127.2af81ab
+ pkgrel = 1
+ url = https://github.com/emacs-evil/evil-surround
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-evil
+ provides = emacs-evil-surround
+ conflicts = emacs-evil-surround
+ source = git+https://github.com/emacs-evil/evil-surround.git
+ sha256sums = SKIP
+
+pkgname = emacs-evil-surround-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46cc94dd8f76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="emacs-evil"
+_gitrepo="evil-surround"
+
+pkgname=emacs-evil-surround-git
+pkgver=r127.2af81ab
+pkgrel=1
+pkgdesc="you will be surrounded (surround.vim for evil, the extensible vi layer)"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-evil')
+makedepends=('git')
+provides=('emacs-evil-surround')
+conflicts=('emacs-evil-surround')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+check() {
+ cd "$_gitrepo"
+ make test
+}
+
+build() {
+ cd "$_gitrepo"
+ make compile
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}