summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-18 14:15:49 -0400
committerAlex Whitt2017-04-18 14:15:49 -0400
commitaf526a12630c9835f6c54f8d7c2944278b79b7a1 (patch)
treeae803f91623fe2833cea70c1534cec0457b480cc
parentf31023163624b2813286ed2b07812d3bed10c356 (diff)
downloadaur-af526a12630c9835f6c54f8d7c2944278b79b7a1.tar.gz
Removing cask dependency and using Emacs itself to build the .el files
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c77d953d3861..091d45e294ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=emacs-expand-region
pkgver=0.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Emacs framework for incrementally selecting semantic regions"
url="https://github.com/magnars/expand-region.el"
arch=('any')
license=('GPL3')
depends=('emacs')
-makedepends=('git' 'cask')
+makedepends=('git')
provides=('emacs-expand-region')
source=("https://github.com/magnars/expand-region.el/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {
cd "${srcdir}/expand-region.el-${pkgver}"
- cask build
+ emacs -Q -batch -L . -f batch-byte-compile *.el
}
package() {