summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-18 14:01:39 -0400
committerAlex Whitt2017-04-18 14:01:39 -0400
commitf31023163624b2813286ed2b07812d3bed10c356 (patch)
tree3845079c5143931e841a3cafa05dace5dc224410
downloadaur-f31023163624b2813286ed2b07812d3bed10c356.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e29643dbeee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-expand-region
+ pkgdesc = Emacs framework for incrementally selecting semantic regions
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/magnars/expand-region.el
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-expand-region
+ conflicts = emacs-expand-region
+ source = https://github.com/magnars/expand-region.el/archive/0.11.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-expand-region
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c77d953d3861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-expand-region
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Emacs framework for incrementally selecting semantic regions"
+url="https://github.com/magnars/expand-region.el"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git' 'cask')
+provides=('emacs-expand-region')
+source=("https://github.com/magnars/expand-region.el/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/expand-region.el-${pkgver}"
+ cask build
+}
+
+package() {
+ cd "${srcdir}/expand-region.el-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/expand-region"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/expand-region/"
+}