summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-08-31 18:32:40 +0200
committersballert2018-08-31 18:32:40 +0200
commit4036c4a2a6b158c1ba520d29426d03708f41f970 (patch)
treeb3018c97a8b387d4003ea0629674ff5cb263e4ab
downloadaur-emacs-expand-region-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a323f2ed588e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-expand-region-git
+ pkgdesc = Emacs extension to increase selected region by semantic units.
+ pkgver = r486.ed32924
+ pkgrel = 1
+ url = https://github.com/magnars/expand-region.el
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-expand-region
+ conflicts = emacs-expand-region
+ source = git+https://github.com/magnars/expand-region.el.git
+ sha256sums = SKIP
+
+pkgname = emacs-expand-region-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53eb4b998192
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+pkgname=emacs-expand-region-git
+pkgver=r486.ed32924
+pkgrel=1
+pkgdesc="Emacs extension to increase selected region by semantic units."
+url="https://github.com/magnars/expand-region.el"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-expand-region')
+conflicts=('emacs-expand-region')
+source=("git+https://github.com/magnars/expand-region.el.git")
+sha256sums=('SKIP')
+_gitname="expand-region.el"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ emacs -Q -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitname"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/expand-region"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/expand-region/"
+}