summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-06-13 09:20:47 -0400
committerAlex Whitt2017-06-13 09:20:47 -0400
commit247665c7e5965545150936e432829f5929d11c67 (patch)
tree33a019492a59e6a8dd3828f00bd869163f28de74
downloadaur-247665c7e5965545150936e432829f5929d11c67.tar.gz
Initial commit (WIP)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rw-r--r--emacs-flycheck-clojure.install27
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac3572a1fd6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jun 13 13:20:17 UTC 2017
+pkgbase = emacs-flycheck-clojure
+ pkgdesc = Flycheck checker for Clojure, using eastwood and core.typed. (WIP PKGBUILD)
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/clojure-emacs/squiggly-clojure
+ install = emacs-flycheck-clojure.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-cider
+ depends = flycheck
+ optdepends = emacs-flycheck-pos-tip: Floating messages at point (to avoid convolluting eldoc information from cider
+ source = emacs-flycheck-clojure-0.1.5.tar.gz::https://github.com/clojure-emacs/squiggly-clojure/archive/0.1.5.tar.gz
+ sha256sums = 7ddc97c028a91512c16613e1b4ac88c97873ef5dae729cb06dfadd341c4ef190
+
+pkgname = emacs-flycheck-clojure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ab3d64fe961
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=squiggly-clojure
+_pkgmaintainer=clojure-emacs
+_pkgdestdirname=flycheck-clojure
+_versionprefix=
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Flycheck checker for Clojure, using eastwood and core.typed. (WIP PKGBUILD)"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs' 'emacs-cider' 'flycheck')
+optdepends=('emacs-flycheck-pos-tip: Floating messages at point (to avoid convolluting eldoc information from cider')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('7ddc97c028a91512c16613e1b4ac88c97873ef5dae729cb06dfadd341c4ef190')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}elisp/"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}/elisp/"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-flycheck-clojure.install b/emacs-flycheck-clojure.install
new file mode 100644
index 000000000000..6ec8266c24ff
--- /dev/null
+++ b/emacs-flycheck-clojure.install
@@ -0,0 +1,27 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'anzu)
+(global-anzu-mode +1)
+
+==> If you are using spaceline or another modeline modifier that
+ references anzu internally:
+
+(setq anzu-cons-mode-line-p nil))
+
+==> Or do the above with use-package:
+
+(use-package anzu
+ :config
+ (global-anzu-mode +1)
+ (setq anzu-cons-mode-line-p nil)) ;If using spaceline or the like
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}