summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsben Haabendal2019-01-11 12:42:43 +0100
committerEsben Haabendal2019-01-11 12:42:43 +0100
commitd8fb39a195f1fa68161cdd0e12e07e9c61a1c6e1 (patch)
treeaaf76784529be8a44ec456c79c3e7751a9501723
parent5e56b84bd7199b60e9d41bbd37a0d31c06f93dae (diff)
downloadaur-d8fb39a195f1fa68161cdd0e12e07e9c61a1c6e1.tar.gz
Update to 3.2.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b257f564c6a..13a1c0bcbba9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = emacs-ghub
pkgdesc = Emacs - Minuscule client library for the Github API
- pkgver = 2.0.1
+ pkgver = 3.2.0
pkgrel = 1
url = http://github.com/magit/ghub
arch = any
license = GPL3
makedepends = git
depends = emacs
+ depends = emacs-dash
+ depends = emacs-graphql
+ depends = emacs-treepy
provides = emacs-ghub
- source = git+https://github.com/magit/ghub.git#tag=v2.0.1
+ source = git+https://github.com/magit/ghub.git#tag=v3.2.0
md5sums = SKIP
pkgname = emacs-ghub
diff --git a/PKGBUILD b/PKGBUILD
index 66dfa52dd5e3..0b832d2262f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=emacs-ghub
_github_org="magit"
_github_repo="ghub"
-pkgver=2.0.1
+pkgver=3.2.0
pkgrel=1
pkgdesc="Emacs - Minuscule client library for the Github API"
arch=('any')
url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
-depends=('emacs')
+depends=('emacs' 'emacs-dash' 'emacs-graphql' 'emacs-treepy')
makedepends=('git')
provides=('emacs-ghub')
source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v${pkgver}")
@@ -17,11 +17,15 @@ md5sums=('SKIP')
build() {
cd "$srcdir/${_github_repo}"
- emacs -batch -Q -L . -f batch-byte-compile ghub.el
+ make LOAD_PATH="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L /usr/share/emacs/site-lisp/graphql -L /usr/share/emacs/site-lisp/treepy -L ${srcdir}/ghub" \
+ lisp doc
}
package() {
cd "$srcdir/${_github_repo}"
mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
- install -m 644 ghub.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ install -m 644 *.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ mkdir -p ${pkgdir}/usr/share/doc/emacs-ghub/
+ install -m 644 *.{pdf,html} ${pkgdir}/usr/share/doc/emacs-ghub
+ cp -r ghub ${pkgdir}/usr/share/doc/emacs-ghub
}