summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfusion8092016-09-18 16:13:51 +1000
committerfusion8092016-09-18 16:13:51 +1000
commit0c00aa47525fe9f58e2c3ba2b79c5bf536e944bf (patch)
treed13ecd109e8dd080cbd6a94fbe9e53dab7885407
downloadaur-0c00aa47525fe9f58e2c3ba2b79c5bf536e944bf.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD158
3 files changed, 204 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c311574759b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Sun Sep 18 06:13:51 UTC 2016
+pkgbase = emacs-git-gtk2
+ pkgver = 25.1.r1
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ source = emacs-git::git+https://github.com/emacs-mirror/emacs.git
+ md5sums = SKIP
+
+pkgname = emacs-git-gtk2
+ pkgdesc = GNU Emacs, the extensible self-documenting text editor — built from git sources.
+ depends = gpm
+ depends = giflib
+ depends = m17n-lib
+ depends = desktop-file-utils
+ depends = alsa-lib
+ depends = imagemagick
+ depends = gtk2
+ provides = emacs
+ conflicts = emacs
+ conflicts = emacs-git
+
+pkgname = emacs-git-docs
+ pkgdesc = GNU Emacs, built from git sources — HTML and PDF documentation package.
+ provides = emacs-docs
+ conflicts = emacs-docs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e067b1759a78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*~
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
+emacs-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b56c7d424655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,158 @@
+# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
+
+#######################################################################
+# CAVEAT LECTOR
+#######################################################################
+#
+# Don't run this on a tmpfs unless you have oodles of RAM.
+# When the official git repo started, the size was about
+# 200MB. As time passes, it is growing more and more.
+# Final directory size after a build is shy of 1Gb!
+# Furthermore, the FSF isn't precisely rich and Savannah
+# network costs aren't cheap. Keep your git checkout!
+#
+# Keeping this directory in a safe place preserves the
+# git repo and the src dir for faster compilation if
+# you want. You may delete the pkg dir after successfully
+# creating a package.
+#
+# "makepkg -i" is your friend.
+#
+#######################################################################
+
+#######################################################################
+#
+# Still reading? Here kid, have enough rope to hang yourself. :-)
+#
+#######################################################################
+
+#######################################################################
+# Assign "YES" to the variable you want enabled, empty otherwise
+#######################################################################
+GTK3="" # Leave empty to compile with gtk+ 2 support.
+LTO= # Enable link-time optimization. Broken.
+CAIRO= # Very broken for me. Use at own risk.
+XWIDGETS= # Use GTK+ native widgets pulled from webkitgtk.
+DOCS_HTML= # Generate and install html documentation.
+DOCS_PDF= # Generate and install pdf documentation.
+#######################################################################
+
+_pkgname=('emacs-git')
+pkgname=("$_pkgname-gtk2" "$_pkgname-docs")
+pkgver=25.1.r1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/emacs/"
+_savannah="git://git.savannah.gnu.org/emacs.git"
+_github="git+https://github.com/emacs-mirror/emacs.git"
+license=('GPL')
+makedepends=('git')
+source=("${_pkgname}::${_github}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ _basever="$(git describe --tags `git rev-list --tags --max-count=1`)"
+ _minver="${_basever//emacs-/}"
+ _minver="${_minver//-/.}"
+ printf "%s.r%s" \
+ "${_minver}" \
+ "$(git rev-list --count ${_basever}..HEAD)"
+}
+
+
+# There is no need to run autogen.sh after first checkout.
+# Doing so, breaks incremental compilation.
+prepare() {
+ cd "$srcdir/${_pkgname}"
+
+ [[ -x configure ]] || ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+
+ # Avoid hardening-wrapper (taken from emacs-pretest, thanks to Thomas Jost).
+ export PATH=$(echo "$PATH" | sed 's!/usr/lib/hardening-wrapper/bin!!g')
+
+ local _conf=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --libexecdir=/usr/lib
+ --localstatedir=/var
+ --mandir=/usr/share/man
+ --with-gameuser=:games
+ --with-sound=alsa
+ --with-xft
+ --with-modules)
+
+#######################################################################
+#######################################################################
+ if [[ $GTK3 = "YES" ]]; then
+ _conf+=('--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings');
+ else
+ _conf+=('--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings');
+ fi
+ if [[ $LTO = "YES" ]]; then _conf+=('--enable-link-time-optimization'); fi
+ if [[ $CAIRO = "YES" ]]; then _conf+=('--with-cairo'); fi
+ if [[ $XWIDGETS = "YES" ]]; then _conf+=('--with-xwidgets'); fi
+#######################################################################
+#######################################################################
+
+ ./configure "${_conf[@]}"
+
+ # Using "make" instead of "make bootstrap" enables incremental
+ # compiling. Less time recompiling. Yay! But if you may
+ # need to use bootstrap sometime, just add it to the command
+ # line.
+ # Please note that incremental compilation implies that you
+ # are reusing your src directory!
+ make
+ make html
+ make pdf
+
+ # You may need to run this if loaddefs.el files become
+ # corrupt.
+ #cd "$srcdir/${_pkgname}/lisp"
+ #make autoloads
+ #cd ../
+}
+
+package_emacs-git-gtk2() {
+ pkgdesc="GNU Emacs, the extensible self-documenting text editor — built from git sources."
+ depends=('gpm' 'giflib' 'm17n-lib' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'gtk2')
+ conflicts=('emacs' 'emacs-git')
+ provides=('emacs')
+
+ cd "$srcdir/${_pkgname}"
+
+ make DESTDIR="$pkgdir/" install
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
+
+ # remove conflict with texinfo
+ rm "$pkgdir"/usr/share/info/info.info.gz
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
+
+ # fix permssions on /var/games
+ mkdir -p "$pkgdir"/var/games/emacs
+ chmod 775 "$pkgdir"/var/games
+ chmod 775 "$pkgdir"/var/games/emacs
+ chown -R root:games "$pkgdir"/var/games
+}
+
+package_emacs-git-docs() {
+ pkgdesc="GNU Emacs, built from git sources — HTML and PDF documentation package."
+ makedepends+=('texlive-core')
+ provides=('emacs-docs')
+ conflicts=('emacs-docs')
+
+ cd "$srcdir/${_pkgname}"
+
+ make DESTDIR="$pkgdir/" install-html
+ make DESTDIR="$pkgdir/" install-pdf
+}