summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:17:47 +0200
committerStefan Husmann2015-06-09 00:17:47 +0200
commit5c1c211990bb791bca97bc12ea4a255105933a02 (patch)
tree50c7cce03a11591fae93c585ca1eb606f321aa16
downloadaur-5c1c211990bb791bca97bc12ea4a255105933a02.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD35
-rw-r--r--emacs-goby.install16
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de1c05ee06eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = emacs-goby
+ pkgdesc = a WYSIWYG presentation tool, which runs on Emacs 22 or later
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.mew.org/~kazu/proj/goby/en/index.html
+ install = emacs-goby.install
+ arch = any
+ license = BSD
+ depends = emacs
+ optdepends = netpbm: for using images
+ optdepends = imagemagic: for making screen dumps
+ source = http://www.mew.org/~kazu/proj/goby/goby-1.1.tar.gz
+ source = LICENSE
+ md5sums = 4bbe196249fcfce034eb868741f6af68
+ md5sums = a774f696f08d52a017e391c578870c4d
+
+pkgname = emacs-goby
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b9365d207ad9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+;;; Copyright Notice:
+
+;; Copyright (C) 2003 Kazu Yamamoto
+;; All rights reserved.
+
+;; Redistribution and use in source and binary forms, with or without
+;; modification, are permitted provided that the following conditions
+;; are met:
+;;
+;; 1. Redistributions of source code must retain the above copyright
+;; notice, this list of conditions and the following disclaimer.
+;; 2. Redistributions in binary form must reproduce the above copyright
+;; notice, this list of conditions and the following disclaimer in the
+;; documentation and/or other materials provided with the distribution.
+;; 3. Neither the name of the author nor the names of its contributors
+;; may be used to endorse or promote products derived from this software
+;; without specific prior written permission.
+;;
+;; THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+;; ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+;; IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+;; PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE
+;; LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+;; CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+;; SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
+;; BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+;; WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
+;; OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+;; IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..447ca9a8a274
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Kan-Ru Chen <kanru@kanru.info>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-goby
+_srcname=goby
+pkgver=1.1
+pkgrel=1
+pkgdesc="a WYSIWYG presentation tool, which runs on Emacs 22 or later"
+arch=('any')
+url="http://www.mew.org/~kazu/proj/goby/en/index.html"
+license=('BSD')
+depends=('emacs')
+optdepends=('netpbm: for using images' 'imagemagic: for making screen dumps')
+source=(http://www.mew.org/~kazu/proj/goby/$_srcname-$pkgver.tar.gz
+ LICENSE)
+md5sums=('4bbe196249fcfce034eb868741f6af68'
+ 'a774f696f08d52a017e391c578870c4d')
+install=$pkgname.install
+
+prepare() {
+ cd "$srcdir/$_srcname-$pkgver"
+ sed -i 's/MKDIR = mkdir/MKDIR = install -d/' Makefile
+}
+
+build() {
+ cd "$srcdir/$_srcname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$_srcname-$pkgver"
+ install -Dm644 "$srcdir/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make PREFIX="$pkgdir/usr" install
+}
diff --git a/emacs-goby.install b/emacs-goby.install
new file mode 100644
index 000000000000..48d3e51179b7
--- /dev/null
+++ b/emacs-goby.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "Please add the following line to your .emacs:"
+ echo "(autoload 'goby \"goby\" nil t)"
+ echo "You will also need to specify some fonts, e.g."
+ echo "(setq goby-helvetica \"arial\")"
+ echo "(setq goby-times \"times new roman\")"
+ echo "(setq goby-courier \"courier new\")"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Please remove the goby-related stuff from your .emacs"
+}