summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-06-02 23:33:00 +0200
committerhaawda2019-06-02 23:33:00 +0200
commit3f75f738e01b9fd26ed68c962cd25cc8bbd030b7 (patch)
treeb662d069cc3c578eb2d827338ed35d812851a532
downloadaur-3f75f738e01b9fd26ed68c962cd25cc8bbd030b7.tar.gz
initial upload
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD58
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca6086e4877b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = emacs-harfbuzz-git
+ pkgdesc = GNU Emacs, git checkout from the harfbuzz branch
+ pkgver = 27.0.50.r136526
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = texlive-core
+ depends = gpm
+ depends = m17n-lib
+ depends = libdbus
+ depends = jansson
+ depends = libmagick
+ depends = webkit2gtk
+ provides = emacs
+ provides = emacs-seq
+ conflicts = emacs
+ options = docs
+ options = !emptydirs
+ source = git://git.savannah.gnu.org/emacs.git#branch=harfbuzz
+ sha256sums = SKIP
+
+pkgname = emacs-harfbuzz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a16f38a10dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-harfbuzz-git
+pkgver=27.0.50.r136526
+pkgrel=1
+pkgdesc="GNU Emacs, git checkout from the harfbuzz branch"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/emacs/"
+license=('GPL')
+depends=('gpm' 'm17n-lib' 'libdbus' 'jansson' 'libmagick' 'webkit2gtk')
+makedepends=('git' 'texlive-core')
+conflicts=('emacs')
+options=('docs' '!emptydirs')
+provides=('emacs' 'emacs-seq')
+source=("git://git.savannah.gnu.org/emacs.git#branch=harfbuzz")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd emacs
+ _mainver=$(grep AC_INIT configure.ac | sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\).\+$/\1/')
+ printf "%s.r%s" "$(echo $_mainver)" "$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd emacs
+ [[ -x configure ]] || ( ./autogen.sh git && ./autogen.sh autoconf )
+ ac_cv_lib_gif_EGifPutExtensionLast=yes PKG_CONFIG_PATH="/usr/lib/imagemagick/pkgconfig" \
+ ./configure --program-transform-name='s/^ctags$/ctags.emacs/' \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/usr/share \
+ --mandir=/usr/share/man \
+ --pdfdir=/usr/share/doc/emacs \
+ --with-modules \
+ --without-gconf \
+ --without-gsettings \
+ --with-imagemagick \
+ --with-xwidgets \
+ --without-pop \
+ --with-gameuser=:games \
+ --disable-build-details \
+ --with-harfbuzz
+ make
+ make pdf
+}
+
+package() {
+ cd emacs
+ _mainver=$(grep AC_INIT configure.ac | sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\).\+$/\1/')
+ make DESTDIR="$pkgdir/" install install-pdf
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/ -exec chown root:root {} \;
+ # Delete compressed .el.gz files. Comment out if needed.
+ # find "$pkgdir"/usr/share/emacs/ -name "*.el.gz" -exec rm {} \;
+ chmod g+w "$pkgdir"/usr/share/games
+ chmod 775 "$pkgdir"/usr/lib/emacs/*/*/update-game-score
+}