summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-25 20:14:41 -0400
committerAlex Whitt2017-04-25 20:14:41 -0400
commit63d84e4873059ccc54a7ac11a9f5beaaacefa973 (patch)
tree65b25ba6a3da38877b51d5fb1446f35e596dd8c0
downloadaur-63d84e4873059ccc54a7ac11a9f5beaaacefa973.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b412115c9712
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Apr 26 00:14:20 UTC 2017
+pkgbase = emacs-helm-projectile
+ pkgdesc = Helm UI for Projectile
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://github.com/bbatsov/helm-projectile
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-helm
+ depends = emacs-projectile
+ source = https://github.com/bbatsov/helm-projectile/archive/v0.14.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-helm-projectile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b0d0a7c44d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-helm-projectile
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="Helm UI for Projectile"
+arch=(any)
+url="https://github.com/bbatsov/helm-projectile"
+license=('GPL3')
+depends=('emacs' 'emacs-helm' 'emacs-projectile')
+source=("https://github.com/bbatsov/helm-projectile/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/helm-projectile-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/helm-projectile-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/helm-projectile/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/helm-projectile/"
+} \ No newline at end of file