summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-10 09:17:30 -0400
committerAlex Whitt2017-05-10 09:17:30 -0400
commit7a96f55fd8e465319a50375267d67e70ecfe6337 (patch)
tree5f7b23bc303bde4f9321bca68e300c5210c17bd0
downloadaur-7a96f55fd8e465319a50375267d67e70ecfe6337.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-highlight-indentation.install25
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a4958cecb14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed May 10 13:17:06 UTC 2017
+pkgbase = emacs-highlight-indentation
+ pkgdesc = Minor modes to highlight indentation guides in emacs.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/antonj/Highlight-Indentation-for-Emacs
+ install = emacs-highlight-indentation.install
+ arch = any
+ license = GPL2
+ depends = emacs
+ source = emacs-highlight-indentation-0.7.0.tar.gz::https://github.com/antonj/Highlight-Indentation-for-Emacs/archive/v0.7.0.tar.gz
+ sha256sums = 4f27c4030ecf0e51a6c3d14556c9e181a7105e150fa11d214a6f0629424def56
+
+pkgname = emacs-highlight-indentation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f9a34d49f05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=Highlight-Indentation-for-Emacs
+_pkgmaintainer=antonj
+_pkgdestdirname=highlight-indentation
+_versionprefix=v
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Minor modes to highlight indentation guides in emacs."
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL2')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('4f27c4030ecf0e51a6c3d14556c9e181a7105e150fa11d214a6f0629424def56')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-highlight-indentation.install b/emacs-highlight-indentation.install
new file mode 100644
index 000000000000..b1debe6f136f
--- /dev/null
+++ b/emacs-highlight-indentation.install
@@ -0,0 +1,25 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'highlight-indentation)
+
+==> Might be a good idea to automatically enable this mode for programming buffers:
+
+(add-hook 'prog-mode-hook #'highlight-indentation-current-column-mode) ; For current column only. My preference. Or:
+(add-hook 'prog-mode-hook #'highlight-indentation-mode) ; To highlight every indentation level
+
+==> Or do the above with use-package:
+
+(use-package highlight-indentation
+ :config
+ (add-hook 'prog-mode-hook #'highlight-indentation-current-column-mode)) ; For programming buffers
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}