summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:17:54 +0200
committerStefan Husmann2015-06-09 00:17:54 +0200
commit04026fb1a1582492d8ca2bc4225b319e0f83deee (patch)
treeb39986304300dcf76536809175e8e02de4b75e62
downloadaur-04026fb1a1582492d8ca2bc4225b319e0f83deee.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--icicles.install16
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e257c6aa8e4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emacs-icicles
+ pkgdesc = an emacs library that enhances minibuffer completion
+ pkgver = 23650
+ pkgrel = 1
+ url = http://www.emacswiki.org/emacs/Icicles
+ install = icicles.install
+ arch = any
+ license = GPL
+ makedepends = wget
+ source = http://www.emacswiki.org/emacs/download/get-icicles.sh
+ md5sums = 93857a3934a576e9fbf69f2c7f355ebd
+
+pkgname = emacs-icicles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3349c739ad0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Richard Murri <admin@richardmurri.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-icicles
+pkgver=23650 # Taken from icicles.el
+pkgrel=1
+pkgdesc="an emacs library that enhances minibuffer completion"
+arch=('any')
+url="http://www.emacswiki.org/emacs/Icicles"
+license=('GPL')
+makedepends=(wget)
+source=(http://www.emacswiki.org/emacs/download/get-icicles.sh)
+md5sums=('93857a3934a576e9fbf69f2c7f355ebd')
+install=icicles.install
+
+build() {
+ [ -d icicles ] && rm -r icicles
+ chmod +x get-icicles.sh
+ ./get-icicles.sh -v
+ cd icicles
+ emacs -Q -batch -L . -f batch-byte-compile *.el || true
+}
+package() {
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/icicles
+ cp -r "$srcdir"/icicles/* "$pkgdir"/usr/share/emacs/site-lisp/icicles
+}
diff --git a/icicles.install b/icicles.install
new file mode 100644
index 000000000000..edaee6e043de
--- /dev/null
+++ b/icicles.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat << EOM
+ Put this code into your ~/.emacs
+ (setq load-path (cons "/usr/share/emacs/site-lisp/icicles" load-path))
+ (require 'icicles)
+
+ Documentation can be found at http://www.emacswiki.org/emacs/Icicles
+
+ The file ring+.el should be loaded after loading the standard
+ GNU file ring.el. So, in your ~/.emacs file, do this:
+ (eval-after-load "ring" '(progn (require 'ring+)))
+EOM
+}
+post_upgrade() {
+ post_install
+} \ No newline at end of file