summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-12-12 00:00:51 +0100
committerhaawda2017-12-12 00:00:51 +0100
commit5bf705afe1142b301ed2f8dabd405c54d2234ada (patch)
treedd2d25a20a76f097313df9ebbe97453b548c92f3
parentfc81285ec58b6e34ff20f83561b60546136a03f0 (diff)
downloadaur-5bf705afe1142b301ed2f8dabd405c54d2234ada.tar.gz
rewrote PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df80d67cf546..62dca5f81724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
# Generated by mksrcinfo v8
-# Mon Dec 11 22:43:08 UTC 2017
+# Mon Dec 11 23:00:51 UTC 2017
pkgbase = emacs-icicles
pkgdesc = an emacs library that enhances minibuffer completion
- pkgver = 23714
+ pkgver = 23708
pkgrel = 1
url = http://www.emacswiki.org/emacs/Icicles
install = icicles.install
arch = any
license = GPL
makedepends = wget
- source = icicles-23714.zip::https://github.com/emacsmirror/icicles/archive/master.zip
- md5sums = b202aa2fb8bffabc74517a41069080a1
pkgname = emacs-icicles
diff --git a/PKGBUILD b/PKGBUILD
index b1826ba7544c..27ced4caa460 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,26 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-icicles
-pkgver=23714 # Taken from icicles.el
+pkgver=23708 # Taken from icicles.el
pkgrel=1
pkgdesc="an emacs library that enhances minibuffer completion"
arch=('any')
url="http://www.emacswiki.org/emacs/Icicles"
license=('GPL')
-source=("icicles-$pkgver.zip::https://github.com/emacsmirror/icicles/archive/master.zip")
-md5sums=('b202aa2fb8bffabc74517a41069080a1')
makedepends=(wget)
install=icicles.install
pkgver() {
- cd icicles-master
- echo $(awk '/Update #:/ {print $4}' icicles.el)
-}
-
-build() {
- cd icicles-master
+ [ -d icicles ] && rm -r icicles
+ mkdir icicles
+ cd icicles
+ wget http://www.emacswiki.org/emacs/download/icicles{,-chg,-cmd1,-cmd2,-doc1,-doc2,-face,-fn,-mac,-mcmd,-mode,-opt,-var}.el
+
+ echo $(awk '/Update #:/ {print $4}' icicles.el)
emacs -Q -batch -L . -f batch-byte-compile *.el || true
}
package() {
install -d "$pkgdir"/usr/share/emacs/site-lisp/icicles
- cp -r "$srcdir"/icicles-master/* "$pkgdir"/usr/share/emacs/site-lisp/icicles
+ cp -r "$srcdir"/icicles/* "$pkgdir"/usr/share/emacs/site-lisp/icicles
}
-