summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-02-05 21:12:01 +0100
committerhaawda2018-02-05 21:12:01 +0100
commitc4e555a0ba0a98d4f6cd520b82b8e63fd51495df (patch)
treead1d1e8513ac5cc3b5499a78474c6419a7200952
parentaac94858a44fede8bdf34407ab9e2dba96c7b79b (diff)
downloadaur-c4e555a0ba0a98d4f6cd520b82b8e63fd51495df.tar.gz
better pkgver function, add epoch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb7d00ba09c3..0caaff5d4ac9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
-# Generated by mksrcinfo v8
-# Mon Dec 11 23:01:42 UTC 2017
pkgbase = emacs-icicles
pkgdesc = an emacs library that enhances minibuffer completion
- pkgver = 23716
+ pkgver = 2018.01.15
pkgrel = 1
+ epoch = 1
url = http://www.emacswiki.org/emacs/Icicles
install = icicles.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 18cea4685e5f..4082e81f8dd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-icicles
-pkgver=23716 # Taken from icicles.el
+epoch=1
+pkgver=2018.01.15 # Taken from icicles.el
pkgrel=1
pkgdesc="an emacs library that enhances minibuffer completion"
arch=('any')
@@ -17,7 +18,11 @@ pkgver() {
cd icicles
wget http://www.emacswiki.org/emacs/download/icicles{,-chg,-cmd1,-cmd2,-doc1,-doc2,-face,-fn,-mac,-mcmd,-mode,-opt,-var}.el
- echo $(awk '/Update #:/ {print $4}' icicles.el)
+ echo $(awk '/Version/ {print $3}' icicles.el)
+}
+
+build() {
+ cd icicles
emacs -Q -batch -L . -f batch-byte-compile *.el || true
}