summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-01 13:01:35 -0400
committerAlex Whitt2017-05-01 13:01:35 -0400
commit1abb984370ae269c311fc5df93b8d1b68edd92e9 (patch)
tree675f841dfe719c9a53276f16f6a6c252f152b747
parentf9c83b7e710c38d3fa68ee61f3d32fc82c6b5054 (diff)
downloadaur-1abb984370ae269c311fc5df93b8d1b68edd92e9.tar.gz
Switching to a more up-to-date fork
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f00c5d5716b2..b69f7e38562f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
# Generated by mksrcinfo v8
-# Mon May 1 16:17:42 UTC 2017
+# Mon May 1 17:01:00 UTC 2017
pkgbase = emacs-iedit
pkgdesc = Edit multiple regions with the same content simultaneously
- pkgver = 0.90
- pkgrel = 3
- url = https://github.com/tsdh/iedit
+ pkgver = 0.9.9.9
+ pkgrel = 1
+ url = https://github.com/victorhge/iedit
arch = any
license = GPL3
depends = emacs
- source = https://github.com/tsdh/iedit/archive/0.90.tar.gz
- source = https://raw.githubusercontent.com/tsdh/iedit/master/iedit-lib.el
- source = https://raw.githubusercontent.com/tsdh/iedit/master/iedit-rect.el
- sha256sums = SKIP
- sha256sums = SKIP
+ source = https://github.com/victorhge/iedit/archive/v0.9.9.9.tar.gz
sha256sums = SKIP
pkgname = emacs-iedit
diff --git a/PKGBUILD b/PKGBUILD
index bebfcf363a8a..5b53dbdfb2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
pkgname=emacs-iedit
-pkgver=0.90
-pkgrel=3
+pkgver=0.9.9.9
+pkgrel=1
pkgdesc="Edit multiple regions with the same content simultaneously"
arch=(any)
-url="https://github.com/tsdh/iedit"
+url="https://github.com/victorhge/iedit"
license=('GPL3')
depends=('emacs')
-source=("https://github.com/tsdh/iedit/archive/${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/tsdh/iedit/master/iedit-lib.el"
- "https://raw.githubusercontent.com/tsdh/iedit/master/iedit-rect.el")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+source=("https://github.com/victorhge/iedit/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
build() {
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
-
cd "${srcdir}/iedit-${pkgver}"
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+ emacs -q --no-splash -batch -L . -f batch-byte-compile iedit{-lib,-rect,}*.el
}
package() {
mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
-
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
-
cd "${srcdir}/iedit-${pkgver}"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
+ install -m644 iedit{-lib,-rect,}.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
}