summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-08-31 19:16:52 +0200
committersballert2018-08-31 19:16:52 +0200
commit220b812a83c4f818d9f9c1314988907dcbe118e3 (patch)
treeb52943f51927f85bf36b90c189821627403d9321
downloadaur-220b812a83c4f818d9f9c1314988907dcbe118e3.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e8eaa7bbc54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-iedit-git
+ pkgdesc = Edit multiple regions simultaneously in a buffer or a region
+ pkgver = r245.2ab2e8b
+ pkgrel = 1
+ url = https://github.com/victorhge/iedit
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-avy
+ provides = emacs-iedit
+ conflicts = emacs-iedit
+ source = git+https://github.com/victorhge/iedit.git
+ sha256sums = SKIP
+
+pkgname = emacs-iedit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7150d87da85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="victorhge"
+_gitrepo="iedit"
+
+pkgname=emacs-iedit-git
+pkgver=r245.2ab2e8b
+pkgrel=1
+pkgdesc="Edit multiple regions simultaneously in a buffer or a region "
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-avy')
+makedepends=('git')
+provides=('emacs-iedit')
+conflicts=('emacs-iedit')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile iedit{-lib,-rect,}*.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 iedit{-lib,-rect,}.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}