summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-27 15:51:39 -0400
committerAlex Whitt2017-04-27 15:51:39 -0400
commit2af59922470ea02443b724a23a65f6f4a299d17f (patch)
tree87021752b50bf1b93b4899fd0e35d1c9548d3280
downloadaur-2af59922470ea02443b724a23a65f6f4a299d17f.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df8a0b4c9825
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 19:50:52 UTC 2017
+pkgbase = emacs-jedi
+ pkgdesc = Python auto-completion for Emacs
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://github.com/tkf/emacs-jedi
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = python-jedi
+ depends = emacs-auto-complete
+ depends = emacs-epc
+ depends = emacs-python-environment
+ provides = emacs-jedi
+ source = https://github.com/tkf/emacs-jedi/archive/v0.2.7.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-jedi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efeb65e1cf82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-jedi
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Python auto-completion for Emacs"
+url="https://github.com/tkf/emacs-jedi"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'python-jedi' 'emacs-auto-complete' 'emacs-epc' 'emacs-python-environment')
+makedepends=('git')
+provides=('emacs-jedi')
+source=("https://github.com/tkf/emacs-jedi/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/emacs-jedi-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile jedi*.el
+}
+
+package() {
+ cd "${srcdir}/emacs-jedi-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/jedi"
+ install -m644 jedi*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/jedi/"
+}