summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-25 12:49:23 +0200
committerhaawda2018-08-25 12:49:23 +0200
commit52896b00ff3b5437873b178c8238e63d0337409e (patch)
tree4514dade3090049b4d9ca90595fa38271aeb0e7d
parent205b8d0fb2ac48747852d5d310a0732fb0d63b23 (diff)
downloadaur-52896b00ff3b5437873b178c8238e63d0337409e.tar.gz
adopted
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53350c2ed92f..aadc62b10b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue May 2 15:13:55 UTC 2017
pkgbase = emacs-jedi
pkgdesc = Python auto-completion for Emacs
pkgver = 0.2.7
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/tkf/emacs-jedi
arch = any
license = GPL3
@@ -15,7 +13,7 @@ pkgbase = emacs-jedi
depends = emacs-python-environment
depends = python-virtualenv
provides = emacs-jedi
- source = emacs-jedi-0.2.7.tar.gz::https://github.com/tkf/emacs-jedi/archive/master.zip
+ source = emacs-jedi-0.2.7.zip::https://github.com/tkf/emacs-jedi/archive/master.zip
sha256sums = SKIP
pkgname = emacs-jedi
diff --git a/PKGBUILD b/PKGBUILD
index 4a01e4161cad..267368cf327c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-jedi
pkgver=0.2.7
-pkgrel=3
+pkgrel=4
pkgdesc="Python auto-completion for Emacs"
url="https://github.com/tkf/emacs-jedi"
arch=('any')
@@ -10,17 +11,17 @@ license=('GPL3')
depends=('emacs' 'python-jedi' 'emacs-auto-complete' 'emacs-epc' 'emacs-python-environment' 'python-virtualenv')
makedepends=('git')
provides=('emacs-jedi')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/tkf/emacs-jedi/archive/master.zip")
+source=("$pkgname-$pkgver.zip::https://github.com/tkf/emacs-jedi/archive/master.zip")
sha256sums=('SKIP')
build() {
- cd "${srcdir}/emacs-jedi-master"
+ cd emacs-jedi-master
emacs -q --no-splash -batch -L . -f batch-byte-compile jedi*.el
}
package() {
- cd "${srcdir}/emacs-jedi-master"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/jedi"
- install -m644 jedi*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/jedi/"
- install -m755 jedi*.py "${pkgdir}/usr/share/emacs/site-lisp/jedi/"
+ cd emacs-jedi-master
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/jedi
+ install -m644 jedi*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/jedi/
+ install -m755 jedi*.py "$pkgdir"/usr/share/emacs/site-lisp/jedi/
}