summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Update Bot2016-06-21 12:29:10 +0200
committerStefan Husmann2016-06-21 12:29:10 +0200
commit7c96a1a9fa462efb4c67acf3f2c881f975dbe448 (patch)
treeadbbd613ecce167e78a6a43e233b74b22ef6b4ce
parent846d1f274fb386ec13f236f1a322fe93dfc8f5f1 (diff)
downloadaur-7c96a1a9fa462efb4c67acf3f2c881f975dbe448.tar.gz
Updated version (20160611 -> 20160621).
Changelog ========= Parse generator methods better (92f5479) js2-define-symbol: Treat const same as let (66fe8de) Merge pull request #342 from shicks/strict (bb0acf5) Add js2-mode-assume-strict custom variable (e5e4fa4) Add a test for #335 as well (bc46db5) Merge branch 'dgreensp-object-rest-spread' (58857dc) Backport for fix for #335 (ae3ed93) Merge pull request #332 from bolivier/master (173d1c8) Merge pull request #333 from daniellandau/master (910520e) Change warning message to not conflict with spec (5ebc7b8) Allow space before global declaration (12586e5) Declare vars created with renaming destructuring (b576cef) Add :warnings-count keyword argument (9586f45) Merge pull request #328 from XeCycle/iname-color (f130121) Colorize imported names as variables (6d22df2) Merge pull request #327 from XeCycle/ckw-as (fa419df) Colorize contextual keywords as & from in import & export (c162f35) Merge pull request #326 from phst/compiler-warning-25 (812df51) Fix a byte compilation warning on Emacs 25 (e265b69) Fix more remaining failures (87f43f3) Merge pull request #325 from phst/all-tests (e44d9e1) Run all tests on 'make test' (16c42ce) Fix the straggler (c988876) Fix the tests broken in the previous commit (de5b31c) Use idle timer to reparse, even when the buffer's just been opened (49954ea) Special-case unary + and - (b2af331) Merge pull request #289 from dgreensp/fix-array-rest (1e1e410) js2-indent-operator-re, js2-declaration-keyword-re: Use symbols boundaries (849e061) Fix computed property generator methods indentation (60f7a2b) Merge pull request #308 from zmwangx/jsdoc-callback-func-method (7b430a3) Add support for JSDoc @callback, @func and @method tags (645d129) Merge pull request #304 from jacksonrayhamilton/fix-void-async-await (b57d129) Simplify await parsing (7e7b6da) Fix compiler warning (97065c8) Refactor async arrow function matching (bacb022) Refactor await parsing to only parse once (57dca37) Fix typo (983f20a) Add tests for of parsing (7e0b11f) Fix await parsing (83d9890) Fix async parsing (d92e772) Fix void parsing (d1bf11f) Remove js2-make-await as unused (ae922a3) Record class declarations for IMenu (f8248df) And move its definition below (757f91d) js2-class-node: Inherit from js2-object-node (4fc6ef8) js2-mode-extend-comment: Don't check that the next line is also commented (be0b00d) Merge pull request #297 from Christoph-D/master (73c0348) Recognize for-of and for-in loops with const (8047d7f) Merge pull request #294 from lunaryorn/patch-1 (fa0aa09) Use SVG for Travis CI badge (5f00a97) Fix a byte-compilation warning (e9227bd) Implement object literal rest/spread (...) (2a904e0) Merge pull request #290 from XeCycle/export-async-fn (4894200) Also parse async function statement in export node (e48e862) Do not print trailing semicolon for export function and class (38aa66b) Fix array destructuring including triple-dot (7fe7165) Adjust js2-print-export-node (f9d28d3) Merge pull request #287 from dgreensp/fix-export-decls (027d546) Exported decls print a little funny; update tests (4cd81c7) Fix semicolons and scoping in exported decls (de6df33) s/will/would (e0972fb) Merge pull request #283 from XeCycle/master-with-async (ec7932d) Add NEWS entry for async/await (d0e4323) Parse async methods (b78d224) Add setImmediate and clearImmediate to js2-node-externs (f652d17) Merge pull request #285 from dgreensp/fix-param-destruct (7abe15e) Fix parsing of param with destructure and default (13f0ffb) Merge pull request #284 from XeCycle/0o-octals (0b1704b) Allow 0o octals in strict mode (29f74b1) Move method type handling to property METHOD_TYPE (d307285) Adapt async/await changes to latest master (dbf4fe9) Merge pull request #278 from redguardtoo/master (4955584) `js2-print-json-path' added (98433fb) Support .jsx file extension too in the example (2a22635) Merge pull request #282 from jacksonrayhamilton/js2-jsx-mode (667d320) Add js2-jsx-mode usage instructions (1f95553) Add NEWS entry for js2-jsx-mode (4c0408b) Copy JSX indentation logic to js2-old-indent.el (7c12f2c) Add js2-jsx-mode (df3f97f) Update MELPA URL (c63c700) Merge pull request #280 from XeCycle/binding-pattern-initializer (221282a) Merge pull request #281 from robbyoconnor/patch-1 (d201a30) Add melpa badges (263852b) Report error for binding initializer outside destructuring (8abf087) Support initializer in destructuring (0555a8a) Merge pull request #279 from XeCycle/class-semicolon-elem (b904d10) Allow semicolons in a class body (c0e0309) Merge pull request #276 from XeCycle/methods (6aba571) Add NEWS entry about rename to method-node (37867af) Refactor: rename getter-setter-node to method-node (d82a58d) Add test on shorthand method name and scoping (3603bc4) Refactor: unify computed property name handling (bfb83dd) Handle open-curlies after newline (cef7731) js2-parse-highlight-prop-get: Take care now to overwrite the js2-function-call face (2cf52e9) Add a test for the latest change (a2be944) Don't misindent generator methods (b1234ca) Also highlight property lookups with the same face (2e7fdb3) Define js2-object-property face (47b215d) Fix 'make all' on older emacsen (fb3f5b6) Merge pull request #266 from jacksonrayhamilton/no-getter-setter-duplicate (00a455f) Don't treat getter / setter pairs as duplicates (34245fe) Remove await-node for 'awayt' and use unary-node (a28a648) Extract contextual keyword highlighting process from a predicate function (b035bd0) Fix docstring to conform to the Elisp guideline (f85abdd) Treat async/await as contextual keywords; Refs #185 (84379dd) Use = instead of eq; Refs #185 (502c14a) Fix typo; Refs #185 (5c97dce) Support ES(7) async/await syntax; Closes #185 (6399bec)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c703a0e3757b..2683f2614186 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 11 03:07:50 UTC 2016
+# Tue Jun 21 10:29:10 UTC 2016
pkgbase = emacs-js2-mode-git
pkgdesc = An improved JavaScript mode for GNU Emacs
- pkgver = 20160611
+ pkgver = 20160621
pkgrel = 1
url = https://github.com/mooz/js2-mode
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 43d7e6a3ad42..c127a673fb5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-js2-mode-git
-pkgver=20160611
+pkgver=20160621
pkgrel=1
pkgdesc="An improved JavaScript mode for GNU Emacs"
arch=('any')