summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-08-31 20:15:48 +0200
committersballert2018-08-31 20:15:48 +0200
commitb478e6aa90c7dc98fbe8df1c335c3639bd41d139 (patch)
tree9a1539d008736a1588ea5dbb5ea2595b9ec59c1a
downloadaur-b478e6aa90c7dc98fbe8df1c335c3639bd41d139.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c8c186a7500
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = emacs-lispy-git
+ pkgdesc = Short and sweet LISP editing
+ pkgver = r2095.0530371
+ pkgrel = 1
+ url = https://github.com/abo-abo/lispy
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-ace-window
+ depends = emacs-hydra
+ depends = emacs-iedit
+ depends = emacs-swiper
+ depends = emacs-zoutline
+ provides = emacs-lispy
+ conflicts = emacs-lispy
+ source = git+https://github.com/abo-abo/lispy.git
+ sha256sums = SKIP
+
+pkgname = emacs-lispy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7fca9d54200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="abo-abo"
+_gitrepo="lispy"
+
+pkgname=emacs-lispy-git
+pkgver=r2095.0530371
+pkgrel=1
+pkgdesc="Short and sweet LISP editing"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-ace-window' 'emacs-hydra' 'emacs-iedit' 'emacs-swiper' 'emacs-zoutline')
+makedepends=('git')
+provides=('emacs-lispy')
+conflicts=('emacs-lispy')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ rm -f lispy-test.el elpa.el
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}