summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-10-21 05:33:46 +0200
committerhaawda2019-10-21 05:33:46 +0200
commit7a045c60731592ff24d18e9b89f55dbec00362a4 (patch)
treeaec192fc8f14084e26c5f7a547d23ab00969ac35
parented6e5e52157cce11ce5b48989e0b72a348b4828f (diff)
downloadaur-7a045c60731592ff24d18e9b89f55dbec00362a4.tar.gz
use cask for building
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 887f78544f01..494624604871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,8 @@ pkgbase = emacs-lsp-mode
url = https://github.com/emacs-lsp/lsp-mode
arch = any
license = GPL3
- depends = emacs
+ makedepends = cask
+ depends = emacs-ht
source = emacs-lsp-mode-6.1.tar.gz::https://github.com/emacs-lsp/lsp-mode/archive/6.1.tar.gz
sha256sums = 7c502ac206ea66b69f32015ac9e0e62a107bc8ecc2371756080914a561cae7e7
diff --git a/PKGBUILD b/PKGBUILD
index 505ed126ce9a..2e4c8a39d94c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,14 @@ pkgdesc="Emacs client/library for the Language Server Protocol"
url="https://github.com/${_gituser}/${_gitrepo}"
arch=('any')
license=('GPL3')
-depends=('emacs')
+depends=('emacs-ht')
+makedepends=('cask')
source=("$pkgname-$pkgver.tar.gz::https://github.com/${_gituser}/${_gitrepo}/archive/$pkgver.tar.gz")
sha256sums=('7c502ac206ea66b69f32015ac9e0e62a107bc8ecc2371756080914a561cae7e7')
build() {
cd ${_gitrepo}-$pkgver
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+ cask build
}
package() {