summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-02-16 22:15:24 +0100
committerhaawda2019-02-16 22:15:24 +0100
commitb0fb8b10532355ef9ebca1940980d17bec283a66 (patch)
treef96bbf63caba48e7034b1d32e7e8510c5a360e2a
downloadaur-b0fb8b10532355ef9ebca1940980d17bec283a66.tar.gz
initial upload
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..085b036402ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = emacs-lsp-mode
+ pkgdesc = Emacs client/library for the Language Server Protocol
+ pkgver = 6.0
+ pkgrel = 1
+ url = https://github.com/emacs-lsp/lsp-mode
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-lsp-mode-6.0.tar.gz::https://github.com/emacs-lsp/lsp-mode/archive/6.0.tar.gz
+ sha256sums = 586e08d61b75c9008ba7bdb38b08e0536d3c6d98ba93f4fe6839109d8cf94842
+
+pkgname = emacs-lsp-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22fec6efc647
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: sballert <sballert@posteo.de>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+_gituser="emacs-lsp"
+_gitrepo="lsp-mode"
+
+pkgname=emacs-lsp-mode
+pkgver=6.0
+pkgrel=1
+pkgdesc="Emacs client/library for the Language Server Protocol"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_gituser}/${_gitrepo}/archive/$pkgver.tar.gz")
+sha256sums=('586e08d61b75c9008ba7bdb38b08e0536d3c6d98ba93f4fe6839109d8cf94842')
+
+build() {
+ cd ${_gitrepo}-$pkgver
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd ${_gitrepo}-$pkgver
+ install -d "$pkgdir"/usr/share/emacs/site-lisp
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp
+}