summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-17 22:10:44 +0200
committersballert2018-09-17 22:10:44 +0200
commit37a6674af8b11c648b8e843f8f1902cf58aa4ac5 (patch)
tree335cf31e01e72355afa867117eebf55fa833479e
downloadaur-37a6674af8b11c648b8e843f8f1902cf58aa4ac5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5945533839a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-lsp-mode-git
+ pkgdesc = Emacs client/library for the Language Server Protocol
+ pkgver = r837.b9f847f
+ pkgrel = 1
+ url = https://github.com/emacs-lsp/lsp-mode
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-lsp-mode
+ conflicts = emacs-lsp-mode
+ source = git+https://github.com/emacs-lsp/lsp-mode.git
+ sha256sums = SKIP
+
+pkgname = emacs-lsp-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af042553e6c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="emacs-lsp"
+_gitrepo="lsp-mode"
+
+pkgname=emacs-lsp-mode-git
+pkgver=r837.b9f847f
+pkgrel=1
+pkgdesc="Emacs client/library for the Language Server Protocol"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-lsp-mode')
+conflicts=('emacs-lsp-mode')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}