summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Kotta2015-07-13 16:12:25 -0500
committerJonathan Kotta2015-07-13 16:12:25 -0500
commit6dd9dd524a87445046aae15fae5b2495dc7e227f (patch)
treeb664acc78944ca5bc08fb292905af26c2340f2f3
downloadaur-6dd9dd524a87445046aae15fae5b2495dc7e227f.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD51
-rw-r--r--emacs.install32
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a1b35904d63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = emacs-lucid
+ pkgdesc = The extensible, customizable, self-documenting real-time display editor (Lucid toolkit version)
+ pkgver = 24.5
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/emacs.html
+ install = emacs.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = librsvg
+ depends = gpm
+ depends = giflib
+ depends = libxpm
+ depends = libotf
+ depends = m17n-lib
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ depends = alsa-lib
+ depends = imagemagick
+ depends = gnutls
+ depends = libxaw
+ provides = emacs
+ conflicts = emacs
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-24.5.tar.xz
+ md5sums = 50560ee00bac9bb9cf0e822764cd0832
+
+pkgname = emacs-lucid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f8422b46321
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Jonathan Kotta <jpkotta AT gmail DOT com>
+# Contributor: megadriver <megadriver at gmx dot com>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
+# Based on emacs from [extra] and emacs-bzr from the AUR
+
+pkgname=emacs-lucid
+pkgver=24.5
+pkgrel=1
+pkgdesc="The extensible, customizable, self-documenting real-time display editor (Lucid toolkit version)"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/emacs/emacs.html"
+license=('GPL3')
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'gnutls' 'libxaw')
+install=emacs.install
+conflicts=('emacs')
+provides=('emacs')
+source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz)
+md5sums=('50560ee00bac9bb9cf0e822764cd0832')
+
+prepare() {
+ cd "$srcdir"/emacs-$pkgver
+}
+
+build() {
+ cd "$srcdir"/emacs-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --with-x-toolkit=lucid --with-xft --without-gconf --without-gsettings
+ make
+}
+
+package() {
+ cd "$srcdir"/emacs-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+ # remove conflict with texinfo
+ rm "$pkgdir"/usr/share/info/info.info.gz
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
+
+ # fix perms on /var/games
+ chmod 775 "$pkgdir"/var/games
+ chmod 775 "$pkgdir"/var/games/emacs
+ chmod 664 "$pkgdir"/var/games/emacs/*
+ chown -R root:games "$pkgdir"/var/games
+}
diff --git a/emacs.install b/emacs.install
new file mode 100644
index 000000000000..6712f44bab84
--- /dev/null
+++ b/emacs.install
@@ -0,0 +1,32 @@
+ICON_PATH=usr/share/icons/hicolor
+INFO_DIR=usr/share/info
+
+INFO_FILES=(ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse
+ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake
+forms gnus htmlfontify idlwave mairix-el message mh-e newsticker nxml-mode
+org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail
+speedbar srecode tramp url vip viper widget wisent woman)
+
+post_install() {
+ gtk-update-icon-cache -q -t -f ${ICON_PATH}
+ update-desktop-database -q
+
+ [[ -x usr/bin/install-info ]] || return 0
+ for f in ${INFO_FILES[@]}; do
+ install-info ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ gtk-update-icon-cache -q -t -f ${ICON_PATH}
+ update-desktop-database -q
+
+ [[ -x usr/bin/install-info ]] || return 0
+ for f in ${INFO_FILES[@]}; do
+ install-info --delete ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
+ done
+}