summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Kotta2022-06-03 17:04:48 -0500
committerJonathan Kotta2022-06-03 17:04:48 -0500
commit7973dbaf8da5f21cc17cbb328fd56fd9f95e3252 (patch)
treee83f5808dc835b3d143677e41e987cfe5626f1e1
parent930a410a9b054a61e004db3e0d35f1ff9b5f4796 (diff)
downloadaur-7973dbaf8da5f21cc17cbb328fd56fd9f95e3252.tar.gz
bump to 28.1 and enable native compilation
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD37
2 files changed, 43 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 736c43d419cb..737834f845ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,32 @@
pkgbase = emacs-lucid
pkgdesc = The extensible, customizable, self-documenting real-time display editor (Lucid toolkit version)
- pkgver = 27.2
+ pkgver = 28.1
pkgrel = 1
url = http://www.gnu.org/software/emacs/emacs.html
arch = x86_64
license = GPL3
- depends = librsvg
- depends = gpm
- depends = m17n-lib
- depends = hicolor-icon-theme
- depends = dbus
depends = alsa-lib
+ depends = dbus
+ depends = gmp
depends = gnutls
+ depends = gpm
+ depends = hicolor-icon-theme
depends = jansson
- depends = libxrandr
- depends = libxinerama
- depends = libxfixes
depends = lcms2
+ depends = libgccjit
+ depends = librsvg
+ depends = libxfixes
+ depends = libxinerama
+ depends = libxrandr
+ depends = m17n-lib
optdepends = desktop-file-utils
- provides = emacs=27
+ provides = emacs=28
conflicts = emacs
- source = ftp://ftp.gnu.org/gnu/emacs/emacs-27.2.tar.xz
- source = ftp://ftp.gnu.org/gnu/emacs/emacs-27.2.tar.xz.sig
- validpgpkeys = E6C9029C363AD41D787A8EBB91C1262F01EB8D39
- validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
- md5sums = 4c3d9ff35b2ab2fe518dc7eb3951e128
- md5sums = SKIP
+ options = debug
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-28.1.tar.xz
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-28.1.tar.xz.sig
+ validpgpkeys = 17E90D521672C04631B1183EE78DAE0F3115E06B
+ sha256sums = 28b1b3d099037a088f0a4ca251d7e7262eab5ea1677aabffa6c4426961ad75e1
+ sha256sums = SKIP
pkgname = emacs-lucid
-
diff --git a/PKGBUILD b/PKGBUILD
index ff7157e6e059..ebb19850e1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,39 @@
# Based on emacs from [extra] and emacs-bzr from the AUR
pkgname=emacs-lucid
-pkgver=27.2
+pkgver=28.1
_pkgver_major=${pkgver/.*}
pkgrel=1
pkgdesc="The extensible, customizable, self-documenting real-time display editor (Lucid toolkit version)"
arch=('x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('librsvg' 'gpm' 'm17n-lib' 'hicolor-icon-theme' 'dbus' 'alsa-lib' 'gnutls' 'jansson' 'libxrandr' 'libxinerama' 'libxfixes' 'lcms2')
-optdepends=('desktop-file-utils')
-conflicts=('emacs')
+depends=(
+ alsa-lib
+ dbus
+ gmp
+ gnutls
+ gpm
+ hicolor-icon-theme
+ jansson
+ lcms2
+ libgccjit
+ librsvg
+ libxfixes
+ libxinerama
+ libxrandr
+ m17n-lib
+)
+optdepends=(desktop-file-utils)
+conflicts=(emacs)
provides=("emacs=$_pkgver_major")
-validpgpkeys=('E6C9029C363AD41D787A8EBB91C1262F01EB8D39'
- '28D3BED851FDF3AB57FEF93C233587A47C207910')
+validpgpkeys=('17E90D521672C04631B1183EE78DAE0F3115E06B')
+options=(debug)
_source_url_prefix="ftp://ftp.gnu.org/gnu/emacs"
source=(${_source_url_prefix}/emacs-$pkgver.tar.xz
${_source_url_prefix}/emacs-$pkgver.tar.xz.sig)
-md5sums=('4c3d9ff35b2ab2fe518dc7eb3951e128'
- 'SKIP')
+sha256sums=('28b1b3d099037a088f0a4ca251d7e7262eab5ea1677aabffa6c4426961ad75e1'
+ 'SKIP')
build() {
cd "$srcdir"/emacs-$pkgver
@@ -31,12 +46,10 @@ build() {
# with PIE (https://debbugs.gnu.org/cgi/bugreport.cgi?bug=18784).
export HARDENING_PIE=0
- export PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig"
-
- ./configure \
+ ./configure \
--prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
--with-x-toolkit=lucid --with-xft --without-gconf --without-gsettings \
- --with-modules \
+ --with-modules --with-native-compilation \
--program-transform-name='s/^ctags$/ctags.emacs/'
make