summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Kotta2016-09-20 15:09:49 -0500
committerJonathan Kotta2016-09-20 15:09:49 -0500
commit9746c3a46d1db83628c11008c0461bc13a865938 (patch)
tree196f8c0fcd55d3614ac8e68bcc3c914d84cd6bd6
parentf6ff1c2aaf88fb853ad43fe25730e917628cb3eb (diff)
downloadaur-9746c3a46d1db83628c11008c0461bc13a865938.tar.gz
update to 25.1
remove emacs.install, because it only does stuff with GTK remove gmalloc patch, only applies to 24.5 remove several deps (namcap) add GPG signatures
-rw-r--r--.SRCINFO21
-rw-r--r--0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch84
-rw-r--r--PKGBUILD29
-rw-r--r--emacs.install32
4 files changed, 21 insertions, 145 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae8ea4b9116b..7d515e5c185d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,29 @@
pkgbase = emacs-lucid
pkgdesc = The extensible, customizable, self-documenting real-time display editor (Lucid toolkit version)
- pkgver = 24.5
- pkgrel = 2
+ pkgver = 25.1
+ pkgrel = 1
url = http://www.gnu.org/software/emacs/emacs.html
- install = emacs.install
arch = i686
arch = x86_64
license = GPL3
depends = librsvg
depends = gpm
- depends = giflib
- depends = libxpm
- depends = libotf
depends = m17n-lib
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = alsa-lib
depends = imagemagick
depends = gnutls
- depends = libxaw
+ depends = libxrandr
+ depends = libxinerama
provides = emacs
conflicts = emacs
- source = ftp://ftp.gnu.org/gnu/emacs/emacs-24.5.tar.xz
- source = 0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch
- md5sums = 50560ee00bac9bb9cf0e822764cd0832
- md5sums = 841bd19e15f8ab3c2ab94e82529ca0ea
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.1.tar.xz
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.1.tar.xz.sig
+ validpgpkeys = B29426DEFB07724C3C35E5D36592E9A3A0B0F199
+ validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
+ md5sums = 4f3d42fb22823a659e16bfa89078a74c
+ md5sums = SKIP
pkgname = emacs-lucid
diff --git a/0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch b/0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch
deleted file mode 100644
index 7819c3500731..000000000000
--- a/0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch
+++ /dev/null
@@ -1,84 +0,0 @@
->From 4b1436b702d56eedd27a0777fc7232cdfb7ac4f6 Mon Sep 17 00:00:00 2001
-From: Wolfgang Jenkner <wjenkner@inode.at>
-Date: Sat, 26 Dec 2015 12:12:02 -0800
-Subject: [PATCH] Always define gmalloc etc. in src/gmalloc.c
-
-This is a work-around to prevent the compiler from using semantic
-knowledge about malloc for optimization purposes. E.g., gcc 5.2
-with -O2 replaces most of calloc's definition by a call to calloc;
-see Bug#22085.
-* src/gmalloc.c [!HYBRID_MALLOC] (malloc, realloc, calloc)
-(aligned_alloc, free): Do not undef. Instead, define these as
-functions (perhaps renamed to gmalloc etc.) in terms of gmalloc etc.
----
- src/gmalloc.c | 36 +++++++++++++++++++++++++++++++++---
- 1 file changed, 33 insertions(+), 3 deletions(-)
-
-diff --git a/src/gmalloc.c b/src/gmalloc.c
-index a88f4ab..90a52a1 100644
---- a/src/gmalloc.c
-+++ b/src/gmalloc.c
-@@ -49,6 +49,17 @@ extern "C"
-
- #include <stddef.h>
-
-+#undef malloc
-+#undef realloc
-+#undef calloc
-+#undef aligned_alloc
-+#undef free
-+#define malloc gmalloc
-+#define realloc grealloc
-+#define calloc gcalloc
-+#define aligned_alloc galigned_alloc
-+#define free gfree
-+#define malloc_info gmalloc_info
-
- /* Allocate SIZE bytes of memory. */
- extern void *malloc (size_t size);
-@@ -1747,6 +1758,42 @@ valloc (size_t size)
- return aligned_alloc (pagesize, size);
- }
-
-+#undef malloc
-+#undef realloc
-+#undef calloc
-+#undef aligned_alloc
-+#undef free
-+
-+void *
-+malloc (size_t size)
-+{
-+ return gmalloc (size);
-+}
-+
-+void *
-+calloc (size_t nmemb, size_t size)
-+{
-+ return gcalloc (nmemb, size);
-+}
-+
-+void
-+free (void *ptr)
-+{
-+ gfree (ptr);
-+}
-+
-+void *
-+aligned_alloc (size_t alignment, size_t size)
-+{
-+ return galigned_alloc (alignment, size);
-+}
-+
-+void *
-+realloc (void *ptr, size_t size)
-+{
-+ return grealloc (ptr, size);
-+}
-+
- #ifdef GC_MCHECK
-
- /* Standard debugging hooks for `malloc'.
---
-2.8.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 8e45e0ccfae8..4d1a9e01eca2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,26 @@
# Based on emacs from [extra] and emacs-bzr from the AUR
pkgname=emacs-lucid
-pkgver=24.5
-pkgrel=2
+pkgver=25.1
+pkgrel=1
pkgdesc="The extensible, customizable, self-documenting real-time display editor (Lucid toolkit version)"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'gnutls' 'libxaw')
-install=emacs.install
+depends=('librsvg' 'gpm' 'm17n-lib' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'gnutls' 'libxrandr' 'libxinerama')
conflicts=('emacs')
provides=('emacs')
-source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz
- 0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch)
-md5sums=('50560ee00bac9bb9cf0e822764cd0832'
- '841bd19e15f8ab3c2ab94e82529ca0ea')
-
-prepare() {
- cd "$srcdir"/emacs-$pkgver
- patch -N -p1 -i ../0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch
-}
+validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199'
+ '28D3BED851FDF3AB57FEF93C233587A47C207910')
+source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz{,.sig})
+md5sums=('4f3d42fb22823a659e16bfa89078a74c'
+ 'SKIP')
build() {
cd "$srcdir"/emacs-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --with-x-toolkit=lucid --with-xft --without-gconf --without-gsettings
+ ./configure \
+ --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
+ --with-x-toolkit=lucid --with-xft --without-gconf --without-gsettings
make
}
@@ -40,9 +36,6 @@ package() {
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
- # remove conflict with texinfo
- rm "$pkgdir"/usr/share/info/info.info.gz
-
# fix user/root permissions on usr/share files
find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
diff --git a/emacs.install b/emacs.install
deleted file mode 100644
index 6712f44bab84..000000000000
--- a/emacs.install
+++ /dev/null
@@ -1,32 +0,0 @@
-ICON_PATH=usr/share/icons/hicolor
-INFO_DIR=usr/share/info
-
-INFO_FILES=(ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse
-ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake
-forms gnus htmlfontify idlwave mairix-el message mh-e newsticker nxml-mode
-org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail
-speedbar srecode tramp url vip viper widget wisent woman)
-
-post_install() {
- gtk-update-icon-cache -q -t -f ${ICON_PATH}
- update-desktop-database -q
-
- [[ -x usr/bin/install-info ]] || return 0
- for f in ${INFO_FILES[@]}; do
- install-info ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- gtk-update-icon-cache -q -t -f ${ICON_PATH}
- update-desktop-database -q
-
- [[ -x usr/bin/install-info ]] || return 0
- for f in ${INFO_FILES[@]}; do
- install-info --delete ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}