summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-01-07 14:38:37 +0100
committerhaawda2018-01-07 14:38:37 +0100
commit42806b17bf3288e8df6d62821da34fb8767331aa (patch)
tree0ead901d4a81655687d3d448425db17bb9fcc7de
parent484c499198cb0f30aabe73260996a81a0a001ada (diff)
downloadaur-42806b17bf3288e8df6d62821da34fb8767331aa.tar.gz
add path for imagemagick6 (libmagick6) support
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--check_IM6.patch13
3 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f78b9158b05..55d8a1a56802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Dec 16 21:22:57 UTC 2017
pkgbase = emacs-lucid-git
pkgdesc = GNU Emacs. Official git master.
- pkgver = 27.0.50.r131513
+ pkgver = 27.0.50.r131681
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
@@ -30,7 +28,9 @@ pkgbase = emacs-lucid-git
options = !emptydirs
options = !makeflags
source = git://git.savannah.gnu.org/emacs.git
+ source = check_IM6.patch
md5sums = SKIP
+ md5sums = 49274bae5626d3a1688a49c54f559e79
pkgname = emacs-lucid-git
diff --git a/PKGBUILD b/PKGBUILD
index 955069d0e6c2..afb35b6851a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-lucid-git
-pkgver=27.0.50.r131513
+pkgver=27.0.50.r131681
pkgrel=1
pkgdesc="GNU Emacs. Official git master."
arch=('i686' 'x86_64')
@@ -14,8 +14,8 @@ makedepends=('git' 'texlive-core')
conflicts=('emacs')
options=('docs' '!emptydirs' '!makeflags')
provides=('emacs')
-source=("git://git.savannah.gnu.org/emacs.git")
-md5sums=('SKIP')
+source=("git://git.savannah.gnu.org/emacs.git" check_IM6.patch)
+md5sums=('SKIP' '49274bae5626d3a1688a49c54f559e79')
pkgver() {
cd "$srcdir/emacs"
@@ -24,13 +24,14 @@ pkgver() {
}
prepare() {
- sed -i 's+SYSTEM_PURESIZE_EXTRA 0+SYSTEM_PURESIZE_EXTRA 512000+' "$srcdir"/emacs/src/puresize.h
+ cd emacs
+ patch -Np1 < $srcdir/check_IM6.patch
}
build() {
cd emacs
- [[ -x configure ]] || ./autogen.sh
- ac_cv_lib_gif_EGifPutExtensionLast=yes \
+ [[ -x configure ]] || ./autogen.sh && ./autogen.sh autoconf
+ ac_cv_lib_gif_EGifPutExtensionLast=yes PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig"\
./configure --program-transform-name='s/^ctags$/ctags.emacs/' \
--prefix=/usr \
--sysconfdir=/etc \
@@ -40,8 +41,9 @@ build() {
--mandir=/usr/share/man \
--pdfdir=/usr/share/doc/emacs \
--with-modules \
- --without-gconf \
--with-xft \
+ --without-gconf \
+ --with-imagemagick \
--without-xwidgets \
--without-pop \
--with-gameuser=:games
diff --git a/check_IM6.patch b/check_IM6.patch
new file mode 100644
index 000000000000..98e081fbda66
--- /dev/null
+++ b/check_IM6.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 4c2644b11d..ab3b78f863 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2524,7 +2524,7 @@ AC_DEFUN
+ ## 6.3.5 is the earliest version known to work; see Bug#17339.
+ ## 6.8.2 makes Emacs crash; see Bug#13867.
+ ## 7 and later have not been ported to; See Bug#25967.
+- IMAGEMAGICK_MODULE="Wand >= 6.3.5 Wand != 6.8.2 Wand < 7"
++ IMAGEMAGICK_MODULE="Wand-6.Q16HDRI"
+ EMACS_CHECK_MODULES([IMAGEMAGICK], [$IMAGEMAGICK_MODULE])
+
+ if test $HAVE_IMAGEMAGICK = yes; then