summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorninrod2018-02-07 14:57:48 -0200
committerninrod2018-02-07 14:57:48 -0200
commit0148bf0773a53c304eba7f9801e3966a531c7618 (patch)
treed581172ed366186ed8912653eb036ccd075fac6b
downloadaur-0148bf0773a53c304eba7f9801e3966a531c7618.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore16
-rw-r--r--Makefile14
-rw-r--r--PKGBUILD63
-rw-r--r--readme.org5
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26d60ecee35b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = emacs-lucid-pre-test
+ pkgdesc = The extensible, customizable, self-documenting real-time display editor, compiled with the lucid toolkit
+ pkgver = 26.0.91
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/emacs.html
+ arch = x86_64
+ license = GPL3
+ depends = libxfixes
+ depends = libmagick6
+ depends = librsvg
+ depends = gpm
+ depends = m17n-lib
+ depends = hicolor-icon-theme
+ depends = dbus
+ depends = alsa-lib
+ depends = gnutls
+ depends = libxrandr
+ depends = libxinerama
+ source = https://github.com/emacs-mirror/emacs/archive/emacs-26.0.91.tar.gz
+ sha1sums = be49ce6c4c42bdb663f8066aba1c4079a6e1bb17
+
+pkgname = emacs-lucid-pre-test
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cf05b66d9cbe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+*~
+*.log
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
+emacs-git \ No newline at end of file
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d463c154c8b8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+build:
+ makepkg
+
+repack:
+ makepkg --force --repackage
+
+install:
+ makepkg --install
+
+test:
+ namcap PKGBUILD && namcap emacs*.pkg.tar.xz
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14dd7eee9c60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: ninrod <filipe.silva at gmail at com>
+
+# ----BEGIN Credits---
+# I have based this PKGBUILD from these sources:
+
+# 1) standard emacs PKGBUILD:
+# Juergen Hoetzel <juergen@archlinux.org> and Renchi Raju <renchi@green.tam.uiuc.edu:
+# https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/emacs
+
+# 2) opinionated emacs from git HEAD:
+# A. López-Valencia: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=emacs-git
+
+# 3) lucid emacs PKGBUILD from AUR:
+# # Maintainer: Jonathan Kotta <jpkotta AT gmail DOT com>
+# Contributor: megadriver <megadriver at gmx dot com>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
+# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=emacs-lucid
+# ----END Credits---
+
+pkgname=emacs-lucid-pre-test
+pkgver=26.0.91
+pkgrel=1
+pkgdesc="The extensible, customizable, self-documenting real-time display editor, compiled with the lucid toolkit"
+arch=('x86_64')
+url="http://www.gnu.org/software/emacs/emacs.html"
+license=('GPL3')
+depends=('libxfixes' 'libmagick6' 'librsvg' 'gpm' 'm17n-lib' 'hicolor-icon-theme' 'dbus' 'alsa-lib' 'gnutls' 'libxrandr' 'libxinerama')
+__mirror_url__=https://github.com/emacs-mirror/emacs/archive
+source=($__mirror_url__/emacs-$pkgver.tar.gz)
+sha1sums=('be49ce6c4c42bdb663f8066aba1c4079a6e1bb17')
+# validpgpkeys=()
+
+build() {
+ cd "$srcdir"/emacs-emacs-$pkgver
+
+ ./autogen.sh
+
+ # For the hardening-wrapper package. Emacs doesn't support building
+ # with PIE (https://debbugs.gnu.org/cgi/bugreport.cgi?bug=18784).
+ export HARDENING_PIE=0
+
+ # with tip from: https://lists.nongnu.org/archive/html/emacs-devel/2017-06/msg00544.html
+ PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig" \
+ ac_cv_lib_gif_EGifPutExtensionLast=yes \
+ ./configure \
+ --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var \
+ --with-x-toolkit=lucid --with-xft --with-modules --with-libotf --with-m17n-flt \
+ --without-gconf --without-gsettings
+ make
+}
+
+package() {
+ cd "$srcdir"/emacs-emacs-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
+}
diff --git a/readme.org b/readme.org
new file mode 100644
index 000000000000..695354fe4c50
--- /dev/null
+++ b/readme.org
@@ -0,0 +1,5 @@
+* emacs-lucid-pre-test
+ - This builds emacs 26 (pre-test) from the source [[https://github.com/emacs-mirror/emacs/releases][release tarballs]] of the (unofficial) emacs mirror on github.
+* usage
+ 1. clone the repo
+ 2. =makepkg --syncdeps --install=