summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsben Haabendal2017-12-15 21:28:21 +0100
committerEsben Haabendal2017-12-15 21:28:21 +0100
commitfa18314109ace6f14c630908a8542e0ccf5046d3 (patch)
treea7025295faac104d3cf9ce148d4cd4c9a9f02863
downloadaur-fa18314109ace6f14c630908a8542e0ccf5046d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--emacs-magit-popup.install24
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98bc068b5584
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-magit-popup
+ pkgdesc = A generic interface for toggling switches and setting options and then invoking an Emacs command which does something with these arguments
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = http://github.com/magit/magit-popup
+ install = emacs-magit-popup.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs>=24.4
+ depends = emacs-dash=2.13.0
+ provides = emacs-magit-popup
+ source = git+https://github.com/magit/magit-popup.git#tag=v2.12.0
+ md5sums = SKIP
+
+pkgname = emacs-magit-popup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae81cff29a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Esben Haabendal <esben@haabendal.dk>
+
+pkgname=emacs-magit-popup
+_github_org="magit"
+_github_repo="magit-popup"
+pkgver=2.12.0
+pkgrel=1
+pkgdesc="A generic interface for toggling switches and setting options and then invoking an Emacs command which does something with these arguments"
+arch=('any')
+url="http://github.com/${_github_org}/${_github_repo}"
+license=('GPL3')
+depends=('emacs>=24.4' 'emacs-dash=2.13.0')
+makedepends=('git')
+provides=('emacs-magit-popup')
+install="${pkgname}.install"
+source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${_github_repo}"
+ unset EMACS
+ make LOAD_PATH="-L /usr/share/emacs/site-lisp/dash" \
+ lisp info
+}
+
+package() {
+ cd "$srcdir/${_github_repo}"
+ mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
+ install -m 644 magit-popup.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ mkdir -p ${pkgdir}/usr/share/info
+ install -m 644 magit-popup.info ${pkgdir}/usr/share/info/
+}
diff --git a/emacs-magit-popup.install b/emacs-magit-popup.install
new file mode 100644
index 000000000000..10c08d4ce5b4
--- /dev/null
+++ b/emacs-magit-popup.install
@@ -0,0 +1,24 @@
+infodir=/usr/share/info
+filelist=(with-editor.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+op=$1
+shift
+$op $*