summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2022-02-25 03:25:26 +0200
committerNocifer2022-02-25 03:25:26 +0200
commit2f0dccfa4c58b28f14f5d68296ab5ece12eb965b (patch)
tree94cb12e84dd4b54ab1001d6fb874d7a464849aaa
parent3722120f653cfa8dc94f3984c9517522a822424d (diff)
downloadaur-2f0dccfa4c58b28f14f5d68296ab5ece12eb965b.tar.gz
v=2.26.4656.102,r=1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26936d7e8c73..22217679dfa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-mozc
pkgdesc = Mozc module for Emacs
- pkgver = 2.26.4646.102
+ pkgver = 2.26.4656.102
pkgrel = 1
url = https://github.com/google/mozc
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = emacs-mozc
makedepends = python
makedepends = qt5-base
depends = emacs
- depends = mozc>=2.26.4646.102
+ depends = mozc>=2.26.4656.102
replaces = emacs-mozc-ut
- source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=cdb6ca32615805af5d2b7aa1dc5a9b300ae1b09f
+ source = emacs-mozc-git::git+https://github.com/google/mozc.git#commit=0dcb977536385e18f88e29b3ae42b07fd5f5f433
sha256sums = SKIP
pkgname = emacs-mozc
diff --git a/PKGBUILD b/PKGBUILD
index 720bdf929681..849fe99f4001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,23 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='emacs-mozc'
-pkgver=2.26.4646.102
+pkgver=2.26.4656.102
pkgrel=1
pkgdesc='Mozc module for Emacs'
arch=('x86_64')
url='https://github.com/google/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('emacs' 'mozc>=2.26.4646.102')
+depends=('emacs' 'mozc>=2.26.4656.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
replaces=('emacs-mozc-ut')
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=cdb6ca32615805af5d2b7aa1dc5a9b300ae1b09f")
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=0dcb977536385e18f88e29b3ae42b07fd5f5f433")
sha256sums=('SKIP')
prepare() {
- cd ${pkgname}-git
+ cd ${pkgname}-git/src
git submodule update --init --recursive
- cd src
-
# Fix the Qt5 include path
sed -i -e 's/x86_64-linux-gnu\/qt5/qt/' config.bzl
@@ -33,7 +31,8 @@ prepare() {
build() {
cd ${pkgname}-git/src
- env PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" bazel build unix/emacs:mozc_emacs_helper --config oss_linux --compilation_mode opt --copt=-fPIC
+ export JAVA_HOME='/usr/lib/jvm/java-11-openjdk/'
+ bazel build unix/emacs:mozc_emacs_helper --config oss_linux --compilation_mode opt
}
package() {